Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1067 closed defect (incomplete)

JavaScript Deobfuscator doesn't work at all in current Nightly

Reported by: barbaz Assignee:
Priority: P2 Milestone:
Module: Unknown Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Mozilla/5.0 (X11; Linux i686; rv:33.0) Gecko/20100101 Firefox/33.0 SeaMonkey/2.30a1
(c-c rev: 43c7f777a37f / m-c rev: 835e22069c1a)

How to reproduce

Open the JavaScript Deobfuscator window.

Observed behaviour

The JavaScript Deobfuscator window does not display any compiled or executed scripts. The following messages appear in the Error Console:

Error: TypeError: Cc['@mozilla.org/js/jsd/debugger-service;1'] is undefined
Source File: chrome://jsdeobfuscator/content/jsdeobfuscator.js
Line: 11

Warning: Synchronous XMLHttpRequest on the main thread is deprecated because of its detrimental effects to the end user's experience. For more help http://xhr.spec.whatwg.org/
Source File: chrome://jsdeobfuscator/content/jsdeobfuscator.js
Line: 41

Error: TypeError: debuggerService is undefined
Source File: chrome://jsdeobfuscator/content/jsdeobfuscator.js
Line: 76

When trying to pause recording, the button locks in the paused state, and this appears in the Error Console:

Error: TypeError: debuggerService is undefined
Source File: chrome://jsdeobfuscator/content/jsdeobfuscator.js
Line: 107

I think this might be related to removal of JSD1 (https://bugzilla.mozilla.org/show_bug.cgi?id=800200)...

Expected behaviour

JavaScript Deobfuscator should record compiled and executed scripts, and display them in the window in real time. Also the Pause button shouldn't lock in the "on" state after being clicked.

Change History (3)

comment:1 Changed 5 years ago by mapx

  • Cc mapx added
  • Platform changed from Unknown to Firefox/Firefox Mobile
  • Priority changed from Unknown to P2

comment:2 Changed 5 years ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

JavaScript Deobfuscator is not part of the Adblock Plus project, see: https://palant.de/2009/02/13/javascript-deobfuscator

There is an issue tracker under https://github.com/palant/jsdeobfuscator/issues

comment:3 Changed 4 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.