Opened 4 years ago

Closed 2 months ago

#1078 closed defect (duplicate)

Report an issue page

Reported by: Gingerbread Man Assignee:
Priority: P5 Milestone: help.eyeo.com 1.0.0
Module: Websites Keywords:
Cc: saroyanm, lisabielik, wspee, jeen Blocked By: #4695
Blocking: Platform: Unknown
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description

  1. https://adblockplus.org/en/bugs#nonbugs

The "Opera" link points to http://help.opera.com/Windows/11.60/en/extensions.html At the very least you should change that to http://help.opera.com/Windows/12.10/en/extensions.html which was the first version to support Adblock Plus. The current version is 22.* but I can't find any useful help page for extensions for that version.

  1. https://adblockplus.org/en/bugs#reporting

This points to the locked Bug Reports forum.

  1. https://adblockplus.org/en/bugs#moved

Sifting through all topics isn't very useful advice. Users who are logged in can easily find their posts by clicking the "View your posts" link at the top. Guests should look under the topic title in the thread list for the name they supplied when posting.

Change History (28)

comment:1 Changed 4 years ago by trev

  • Priority changed from P2 to P3

comment:2 Changed 4 years ago by trev

  • Component changed from Infrastructure to Websites

comment:3 Changed 3 years ago by saroyanm

  • Owner set to saroyanm

comment:4 Changed 3 years ago by saroyanm

  • Review URL(s) modified (diff)

comment:5 Changed 3 years ago by saroyanm

  • Status changed from new to reviewing

comment:6 Changed 3 years ago by saroyanm

  • Ready set

comment:7 follow-up: Changed 3 years ago by saroyanm

  • Cc fhd greiner added
  • Resolution set to rejected
  • Review URL(s) modified (diff)
  • Status changed from reviewing to closed

As discussed with @greiner internally, this ticket no more valid,
Currently we are no more supporting Opera version 12.10.

In addition make sense to update that page (in separate ticket), also make sense changing the links to the forum or user group where the current links are no more valid (ex. Opera), also make sense to add other supported browsers (Yandex Browser, Maxthon) to the mentioned section.

comment:8 Changed 3 years ago by saroyanm

  • Owner saroyanm deleted

comment:9 in reply to: ↑ 7 ; follow-up: Changed 3 years ago by greiner

  • Resolution rejected deleted
  • Status changed from closed to reopened

Replying to saroyanm:

As discussed with @greiner internally, this ticket no more valid,
Currently we are no more supporting Opera version 12.10.

Since this ticket tackles multiple different issues, the provided argument only renders the first issue in the list invalid. We should make sure that all the issues are addressed.

Note that separate issues should be reported as such to avoid confusion. You can reject this ticket if you restrict it to the first issue and create separate issues for the remaining ones. For now, I reopened the ticket, however, since it still contains valid issues.

Replying to saroyanm:

In addition make sense to update that page (in separate ticket)

Please also post a link to the new ticket here for reference.

comment:10 in reply to: ↑ 9 ; follow-ups: Changed 3 years ago by Gingerbread Man

How is point 1. not valid? The link points to the extensions help page for Opera 11.60. How is that not a problem when you no longer support even Opera 12.10, which is newer?

Speaking of Opera, see #121 and #1975.

Did I understand correctly? Did you just ignore this easily fixable ticket for 9 months, then tell me that I should file an additional 2 tickets for this single page?
If so, that's not an even remotely reasonable demand. So no, I won't be doing that. Nor will I be splitting #459 into 7 tickets, #688 into 7 tickets, or #1077 into 20 tickets.

comment:11 in reply to: ↑ 10 Changed 3 years ago by greiner

Replying to Gingerbread Man:

How is point 1. not valid? The link points to the extensions help page for Opera 11.60. How is that not a problem when you no longer support even Opera 12.10, which is newer?

It is a problem, that's correct. That's exactly why we're thinking about replacing those links alltogether with something more useful like links to support pages for the respective browsers.

Did I understand correctly? Did you just ignore this easily fixable ticket for 9 months, then tell me that I should file an additional 2 tickets for this single page?

Not sure why nobody tackled this before but my comment was just a suggestion for saroyanm. It's up to him to decide how to continue with this. Generally, collecting related changes in one issue should not be a problem but it can slow down the process because it may spawn multiple separate discussions. In this case splitting the first issue off from the rest allows us to work on them independently.

comment:12 Changed 3 years ago by saroyanm

  • Cc saroyanm added

comment:13 in reply to: ↑ 10 Changed 3 years ago by saroyanm

Replying to Gingerbread Man:

How is point 1. not valid? The link points to the extensions help page for Opera 11.60. How is that not a problem when you no longer support even Opera 12.10, which is newer?

We need to find some useful link for this, @greiner is right that he reopens the ticket I should created a new tick before closing this.

Did I understand correctly? Did you just ignore this easily fixable ticket for 9 months, then tell me that I should file an additional 2 tickets for this single page?
If so, that's not an even remotely reasonable demand. So no, I won't be doing that. Nor will I be splitting #459 into 7 tickets, #688 into 7 tickets, or #1077 into 20 tickets.

NO need for you to do that, I was planing to do that after closing this ticket and handle similar website related tickets, you don't need to split them up to several tickets I think most of the issues will be covered with updating the content in website, can't say exact time but we are planing that, so we will create appropriate tickets and will take into account all the information you have already provided. So sorry for the confusion, anyway we are planing in future update all that documentation and surely this old tickets that had not been taken into the account for a while will be taken into the account.

comment:14 Changed 2 years ago by juliandoucette

  • Owner set to juliandoucette
  • Tester set to Unknown

comment:15 Changed 2 years ago by juliandoucette

  • Owner juliandoucette deleted

comment:16 Changed 2 years ago by juliandoucette

  • Ready unset

Links in the description are out-of-date. This issue will be addressed this quarter or next via the help center. If that doesn't get moving soon, I will implement a temporary fix.

comment:17 Changed 2 years ago by juliandoucette

  • Cc lisabielik added

I think we should implement a temporary fix. @lisa && @philll will you please review and update this ticket?

comment:18 Changed 2 years ago by lisabielik

I believe the current way to report issues (other than in Firefox) is to go to the forum and sort of figure it out on your own. These are the updated FAQs regarding issues.

What if Adblock Plus blocks too much content?

In rare instances, Adblock Plus may prevent some websites from functioning correctly. This is typically not a bug but rather a problem with the filters (or filter subscription). The filter lists may be directing Adblock Plus to block something that should be allowed. To verify that the issue lies within the filter list, temporarily disable Adblock Plus. If the issue is fixed after disabling Adblock Plus, you can be certain that the problem lies within the filters.

How to report bad filters...

Chrome, Internet Explorer, Maxthon, Opera and Safari

  1. Go to the [forum](https://adblockplus.org/forum/).
  2. Click the appropriate topic (e.g. Adblock Plus for Chrome Support).
  3. Click the first topic (e.g. Read this if you still see ads on Chrome).

Firefox

  1. Click the Adblock Plus icon and select Report issue on this page.

<br/>The *Issue Reporter* window opens.

  1. Select the radio button labeled Adblock Plus is blocking too much.
  2. Click Next.
  3. Attach a screenshot and click Next.
  4. Enter your email address in the *Email* field.
  5. Optionally, enter a comment in the *Comment* field.
  6. Click Send report.
  7. Your report is automatically sent to the filter hosts.

<br/>Tip: Filter hosts may not be able reply to your issue directly, so please provide any additional information that will help make the problem reproducible.

I accidentally blocked something. How do I unblock it?

Chrome

  1. Mac OS X and Linux: Click Chrome and select Preferences.

<br/>Windows: Click the Chrome menu icon and select Settings.
<br/>The *Settings* window opens.

  1. Select Extensions from the left menu.
  2. Locate Adblock Plus and click Options.

<br/>The *Adblock Plus Options* window opens.

  1. Select the Add your own filters tab.
  2. Select the filter you wish to remove and click Remove selected.

Firefox

  1. Mac OS X and Linux: From the menu bar, click Tools and select Add-ons.

<br/>Windows: Click the Firefox menu icon and select Add-ons.
<br/>The *Add-ons Manager* tab opens.

  1. Select Extensions from the left menu.
  2. Select Adblock Plus and click Preferences (Mac)/Options (Windows).
  3. Click Filter preferences.

The *Adblock Plus Filter preferences* window opens.

  1. Select the Custom Filters tab.
  2. Right-click a group and select Show/hide filters.
  3. Remove the respective filters from the right window.

Opera

  1. Click Opera and select Extensions manager.

<br/>The *Extensions* tab opens.

  1. Select All from the left menu.
  2. Locate Adblock Plus and click Options.

<br/>The *Adblock Plus Options* tab opens.

  1. Select the Add your own filters tab.
  2. Select the filter you want to remove and click Remove selected.

Safari

  1. Click the Adblock Plus icon and select Options.

<br/>The *Adblock Plus Options* page opens.

  1. Select the Add your own filters tab.
  2. Select the filter you want to remove and click Remove selected.

I installed Adblock Plus, but I still see ads. Why?

Verify the following:

Adblock Plus is enabled.

Chrome

  1. Click the Chrome menu icon and select Settings.
  2. Select Extensions from the left menu.
  3. Locate and verify that Enabled is checked.


Firefox

  1. Mac OS X and Linux: From the menu bar, click Tools and select Add-ons.

<br/>Windows: Click the Firefox menu icon and select Add-ons.

  1. Select Extensions from the left menu.
  2. Click Enable.

<br/>Tip: The Enable button is only visible if is disabled.

Internet Explorer

  1. If the icon appears gray in color, click it and deselect Disable everywhere.

<br/>The Adblock Plus icon is now enabled and appears red in color.

Opera

  1. Click Opera and select Extensions manager.
  2. Click All and locate Adblock Plus.
  3. Click Enable.

<br/>Tip: The Enable button is only visible if Adblock Plus is disabled.

Safari

  1. Click Safari and select Preferences.

<br/>The *Preferences* window opens.

  1. Select the Extensions tab.
  2. Select the checkbox labeled Enable Adblock Plus.

You are subscribed to a filter list.

Chrome

  1. Mac OS X and Linux: Click Chrome and select Preferences.

<br/>Windows: Click the Chrome menu icon and select Settings.

  1. Select Extensions from the left menu.
  2. Locate Adblock Plus and click Options.

<br/>The *Adblock Plus Options* tab opens.

  1. Ensure at least one filter list is selected.

Firefox

  1. Mac OS X and Linux: From the menu bar, click Tools and select Add-ons.

<br/>Windows: Click the Firefox menu icon and select Add-ons.
<br/>The *Add-ons Manager* tab opens.

  1. Select Extensions from the left menu.
  2. Select Adblock Plus and click Preferences (Mac)/Options (Windows).
  3. Click Filter preferences.

<br/>The *Adblock Plus Filter Preferences* window opens.

  1. Ensure at least one filter list is selected.

Internet Explorer

  1. Click the Adblock Plus icon and select Settings.

<br/>The *Adblock Plus Options* page opens.

  1. Ensure at least one filter list is selected.

Opera

  1. Click Opera and select Extensions manager.

<br/>The *Extensions* tab opens.

  1. Click All from the left menu.
  2. Locate Adblock Plus and click Options.

<br/>The *Adblock Plus Options* tab opens.

  1. Ensure at least one filter list is selected.

Safari

  1. Click the Adblock Plus icon and select Options.

<br/>The *Adblock Plus Options* page opens.

  1. Ensure at least one filter list is selected.

The website is not whitelisted by Adblock Plus.

Chrome

  1. Mac OS X and Linux: Click Chrome and select Preferences.

<br/>Windows: Click the Chrome menu icon and select Settings.

  1. Select Extensions from the left menu.
  2. Locate Adblock Plus and click Options.

<br/>The *Adblock Plus Options* tab opens.

  1. Select the Whitelisted domains tab.
  2. If a website that you don't want to view ads on appears in the box, select the website and click Remove selected.

Firefox

  1. Mac OS X and Linux: From the menu bar, click Tools and select Add-ons.

<br/>Windows: Click the Firefox menu icon and select Add-ons.
<br/>The *Add-ons Manager* tab opens.

  1. Select Extensions from the left menu.
  2. Locate Adblock Plus and click Preferences (Mac)/Options (Windows).
  3. Click Filter preferences.

<br/>The *Adblock Plus Filter Preferences* window opens.

  1. Select the Custom filters tab.
  2. Select a filter group, click Actions and select Show/hide filters.
  3. If a filter rule appears in the right window, do one of the following:
    • Select the rule, click Filter actions and select Delete.
    • Uncheck the Enabled box that applies to the rule.

Opera

  1. Click Opera and select Extensions manager.

<br/>The *Extensions* tab opens.

  1. Click All from the left menu.
  2. Locate Adblock Plus and click Options.

<br/>The *Adblock Plus Options* tab opens.

  1. Select the Whitelisted domains tab.
  2. If a website that you don't want to view ads on appears in the box, select the website and click Remove selected.

Safari

  1. Click the Adblock Plus icon and select Options.

<br/>The *Adblock Plus Options* page opens.

  1. Select the Whitelisted domains tab.
  2. If a website that you don't want to view ads on appears in the box, select the website and click Remove selected.

I'm still seeing ads. What now?

This may be the result of a malicious browser extension. Please refer to this [guide](https://easylist.adblockplus.org/blog/2013/03/09/ads-caused-by-malware-or-adware-extensions-or-plugins) for information on how to detect and purge such extensions.

You may consider [resetting Firefox](https://support.mozilla.org/en-US/kb/refresh-firefox-reset-add-ons-and-settings?redirectlocale=en-US&redirectslug=reset-firefox-easily-fix-most-problems) or [creating a new Chrome browser user profile](https://support.google.com/chrome/answer/142059).

If you still see ads after following these recommendations, please report the website(s) in the [forum](https://adblockplus.org/forum/).

comment:19 Changed 19 months ago by juliandoucette

  • Priority changed from P3 to Unknown

comment:20 Changed 19 months ago by juliandoucette

  • Blocked By 4695 added
  • Priority changed from Unknown to P5

comment:21 Changed 19 months ago by juliandoucette

  • Blocked By 4695 removed

comment:22 Changed 19 months ago by juliandoucette

  • Blocked By 4695 added

comment:23 Changed 19 months ago by juliandoucette

  • Priority changed from P5 to Unknown

comment:24 Changed 14 months ago by juliandoucette

  • Keywords adblockplus.org content removed
  • Priority changed from Unknown to P5

comment:25 Changed 11 months ago by juliandoucette

  • Cc wspee jeen added; fhd greiner removed

@wspee can you please get to the bottom of this and update the description.

comment:26 Changed 5 months ago by jeen

  • Milestone set to help.eyeo.com 1.0.0

comment:27 Changed 5 months ago by jeen

https://adblockplus.org/en/bugs#nonbugs
The "Opera" link points to http://help.opera.com/Windows/11.60/en/extensions.html At the very least you should change that to ​
http://help.opera.com/Windows/12.10/en/extensions.html which was the first version to support Adblock Plus. The current version is 22.* but I can't find any useful help page for extensions for that version.

  • The link for this will be updated to link to the help centre article, once that goes live. I am adding it to the Help Center milestone to keep track of this.

https://adblockplus.org/en/bugs#reporting
This points to the locked Bug Reports forum.

​- This seems to now be fixed.

https://adblockplus.org/en/bugs#moved
Sifting through all topics isn't very useful advice. Users who are logged in can easily find their posts by clicking the "​View your posts" link at the top. Guests should look under the topic title in the thread list for the name they supplied when posting.

  • Agreed we could probably provide more useful instructions. This can also be moved to the Help Center.

comment:28 Changed 2 months ago by ire

  • Resolution set to duplicate
  • Status changed from reopened to closed
Note: See TracTickets for help on using tickets.