Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1079 closed defect (incomplete)

Customizations add-on - multiple issues

Reported by: Gingerbread Man Assignee: saroyanm
Priority: P2 Milestone:
Module: Extensions-for-Adblock-Plus Keywords:
Cc: trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Firefox 33.0a1 (2014-07-17) • Adblock Plus 2.6.3.3848 • Customizations for Adblock Plus 1.0.4a.78

  1. "Toolbar/add-on bar item display". Icon and Text produces alignment issues (see attached screenshot).
  2. "Special icon for whitelisted pages". This produces a horrible-looking, low-res and jagged icon on applicable pages.
  3. "Toolbar/add-on bar item left-click action". Switching to something other than the default causes icon and text alignment issues by introducing a separator to the left side of the dropmarker.
  4. "Non-intrusive ads display in preferences". Switching to Filter Subscription simply causes the option to disappear from the Filter Preferences window.

Seamonkey 2.26.1 • Adblock Plus 2.6.3 • Customizations for Adblock Plus 1.0.3

  1. "Toolbar/add-on bar item display" has no effect.
  2. Same as the Firefox issue.
  3. "Toolbar/add-on bar item left-click action" has no effect.
  4. Same as the Firefox issue.

Forum thread

https://adblockplus.org/forum/viewtopic.php?f=1&t=24095
Please note the additional issue described there: the toolbar item remains stuck on text only and "Toolbar/add-on bar item display" has no effect. Since I'm convinced that's caused by the Classic Theme Restorer add-on, I didn't mention it.

Attachments (1)

customizations_iconandtext.png (3.5 KB) - added by Gingerbread Man 5 years ago.
customizations_iconandtext.png

Download all attachments as: .zip

Change History (19)

Changed 5 years ago by Gingerbread Man

customizations_iconandtext.png

comment:1 Changed 5 years ago by saroyanm

  • Owner set to saroyanm

comment:2 follow-ups: Changed 5 years ago by trev

  • Cc trev added

"Toolbar/add-on bar item display". Icon and Text produces alignment issues (see attached screenshot).

That would be an issue with the Firefox theme on Windows, no such issue on OS X. Are you using the default theme?

"Special icon for whitelisted pages". This produces a horrible-looking, low-res and jagged icon on applicable pages.

Feel free to provide a better icon :). This feature is meant for people who miss that icon - and there is certainly a reason why we removed it from Adblock Plus.

"Toolbar/add-on bar item left-click action". Switching to something other than the default causes icon and text alignment issues by introducing a separator to the left side of the dropmarker.

That's again a Firefox theme issue.

"Non-intrusive ads display in preferences". Switching to Filter Subscription simply causes the option to disappear from the Filter Preferences window.

That's by design - this preference makes sure "acceptable ads" are treated like any filter subscription. Meaning: if it is there, it is displayed in the list like any other subscription. And if it isn't there then it just isn't there.

SeaMonkey: "Toolbar/add-on bar item left-click action" has no effect.

No visible effect you mean? That's expected given the default icon placement in SeaMonkey. It should change the left-click action however.

SeaMonkey: "Toolbar/add-on bar item display" has no effect.

Seems to be a valid issue, needs to be tested.

comment:3 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by saroyanm

Replying to trev:

"Toolbar/add-on bar item display". Icon and Text produces alignment issues (see attached screenshot).

That would be an issue with the Firefox theme on Windows, no such issue on OS X. Are you using the default theme?

Yes, the issue looks to be only in windows, seams like it's caused by current style:
http://mxr.mozilla.org/mozilla-central/source/browser/themes/windows/browser.css#697

"Toolbar/add-on bar item left-click action". Switching to something other than the default causes icon and text alignment issues by introducing a separator to the left side of the dropmarker.

That's again a Firefox theme issue

It's looks to be caused by "-moz-box-orient: vertical;" rule:
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/linux/global/toolbarbutton.css#102
http://mxr.mozilla.org/mozilla-central/source/toolkit/themes/windows/global/toolbarbutton.css#134

comment:4 in reply to: ↑ 3 Changed 5 years ago by saroyanm

SeaMonkey: "Toolbar/add-on bar item left-click action" has no effect.

It's seams like causing status bar item.

comment:5 in reply to: ↑ 2 ; follow-up: Changed 5 years ago by saroyanm

Replying to trev:

SeaMonkey: "Toolbar/add-on bar item display" has no effect.

Works for me, the only things that it's not having effect on status bar item, anyway not sure if the status bar item also should be changed by this option.

comment:6 Changed 5 years ago by saroyanm

As far as Wladimir moved actual issues to current tickets:
https://issues.adblockplus.org/ticket/1140
https://issues.adblockplus.org/ticket/1139
https://issues.adblockplus.org/ticket/1138

I guess this ticket can be closed.

comment:7 Changed 5 years ago by saroyanm

  • Resolution set to invalid
  • Status changed from new to closed

comment:8 in reply to: ↑ 5 ; follow-ups: Changed 5 years ago by trev

For reference: I filed #1138, #1139 and #1140 which are slightly related.

Replying to saroyanm:

SeaMonkey: "Toolbar/add-on bar item display" has no effect.

Works for me, the only things that it's not having effect on status bar item, anyway not sure if the status bar item also should be changed by this option.

Yes, works for me as well. It isn't supposed to have any effect on the status bar icon - the status bar in SeaMonkey isn't a toolbar.

SeaMonkey: "Toolbar/add-on bar item left-click action" has no effect.

I verified that this works correctly. Once again, this doesn't apply to the status bar icon however - that one is a different beast in SeaMonkey.

I agree with the resolution, there doesn't seem to be anything here that we could work on. Filing a Firefox bug for the text&icon theme issue is pointless - this is no longer a supported icon display mode with the Australis theme. For the issues caused by the separator (meaning <toolbarbutton type="menu-button"> display) filing a bug similar to https://bugzilla.mozilla.org/show_bug.cgi?id=971246 might make sense. In general, I recommend creating one issue for each problem, discussing several unrelated problems in one issue quickly becomes very messy.

comment:9 in reply to: ↑ 8 Changed 5 years ago by saroyanm

Replying to trev:

For the issues caused by the separator (meaning <toolbarbutton type="menu-button"> display) filing a bug similar to https://bugzilla.mozilla.org/show_bug.cgi?id=971246 might make sense.

Seams like there is already a similar bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=547420

comment:10 Changed 5 years ago by trev

No, that one is about the separator in general - the separator makes sense, even though a better solution might be possible. The alignment issues if any are Australis-related, a bug on those would be significantly newer.

comment:11 Changed 5 years ago by saroyanm

I've filed a bug:
https://bugzilla.mozilla.org/show_bug.cgi?id=1043935
Can you please have a look on it Wladimir

comment:12 in reply to: ↑ 8 Changed 5 years ago by saroyanm

Replying to trev:

I agree with the resolution, there doesn't seem to be anything here that we could work on. Filing a Firefox bug for the text&icon theme issue is pointless - this is no longer a supported icon display mode with the Australis theme. For the issues caused by the separator (meaning <toolbarbutton type="menu-button"> display) filing a bug similar to https://bugzilla.mozilla.org/show_bug.cgi?id=971246 might make sense.

Wladimir I think I misunderstand your point, Do we also have aligning issue realated to type="menu-button" beside the one with text&icon ?

comment:13 Changed 5 years ago by trev

It seems that I misunderstood the original report - if the alignment issue with the separator only shows up if icon is displayed with text then there is indeed no bug to be filed. As Gijs Kruitbosch confirmed, icon with text is no longer a supported mode with the Australis theme.

comment:14 follow-up: Changed 5 years ago by trev

Filed one more follow-up issue: #1155

comment:15 in reply to: ↑ 14 Changed 5 years ago by saroyanm

Replying to trev:

Filed one more follow-up issue: #1155

That's a good one.
Also created another issue that just noticed: #1156

comment:16 in reply to: ↑ description ; follow-up: Changed 5 years ago by Gingerbread Man

Replying to Gingerbread Man:

"Non-intrusive ads display in preferences". Switching to Filter Subscription simply causes
the option to disappear from the Filter Preferences window.

It turns out that only happens if the "Allow…" option is unchecked. Confusing, but I guess intentional.

Replying to saroyanm:

SeaMonkey: "Toolbar/add-on bar item display" has no effect.

Works for me, the only things that it's not having effect on status bar item, anyway not sure
if the status bar item also should be changed by this option.

Given ticket #1140, and that the status bar icon is the default in Seamonkey, yes, it should. Otherwise, just say up front that this add-on doesn't support Seamonkey. It would be better than having features that don't work; don't expect the average user to know — or care about — technical aspects like the difference between the status bar and a toolbar.

comment:17 in reply to: ↑ 16 Changed 5 years ago by saroyanm

Replying to Gingerbread Man:

Given ticket #1140, and that the status bar icon is the default in Seamonkey, yes, it should. Otherwise, just say up front that this add-on doesn't support Seamonkey. It would be better than having features that don't work; don't expect the average user to know — or care about — technical aspects like the difference between the status bar and a toolbar.

I agree with you that the toolbar and status bar can lead to confusion for people who don't care about the difference.
But anyway I wouldn't say that the addon don't support Seamonkey because of people don't care about the difference and while features still work for toolbaritem.

Wladimir what you think, does it make sense to implement feature so people can also change look of status bar item and change default left click action for statusbar item also ? Should it be separate option ?

comment:18 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.