Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1080 closed defect (incomplete)

[trac] Different error message for non-existent issues when logged out

Reported by: greiner Assignee:
Priority: P4 Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Logged out of issues.adblockplus.org

How to reproduce

  1. Log out of issues.adblockplus.org if you're logged in
  2. Go to https://issues.adblockplus.org/ticket/9999999
  3. Log in at issues.adblockplus.org
  4. Go to https://issues.adblockplus.org/ticket/9999999

Observed behaviour

At (2) the following error message is shown: TICKET_VIEW privileges are required to perform this operation on Ticket #9999999. You don't have the required permissions.

At (4) the following error message is shown: Ticket 9999999 does not exist.

Expected behaviour

At (2) and (4) the following error message is shown: Ticket 9999999 does not exist.

Change History (3)

comment:1 Changed 5 years ago by philll

  • Resolution set to invalid
  • Status changed from new to closed

Well, the ticket in fact does not exist, so what's the point of this issue? Asking for privileges when not logged in might be a tad weird but not really something I would care for.

comment:2 Changed 5 years ago by greiner

If we don't want to fix this please resolve it as "wontfix" instead since the issue itself is valid as you acknowledged.

comment:3 Changed 5 years ago by philll

Well no, I don't regard this a valid bug. It is reproducible, but not a bug at all. The closest I could interpret here if "weird behaviour" for the missing permissions message, but not exactly a bug.

Note: See TracTickets for help on using tickets.