Opened 5 years ago

Closed 4 years ago

#1104 closed defect (fixed)

Cannot uncheck Disable on website option in tool bar

Reported by: passbrains Assignee: sergz
Priority: P3 Milestone: Adblock-Plus-for-Internet-Explorer-1.5
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr@… Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5081266177179648/
http://codereview.adblockplus.org/5115380229996544/

Description (last modified by oleksandr)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AIN-16

Environment

none of assigned configurations
ABP version 1.2.636.0

How to reproduce

Tested on - Win 7 64 bit IE 11

  1. Open IE browser with extension installed
  2. Click on ABP icon and select settings
  3. Click Manage
  4. Add 'fotor.com'  and close settings
  5. Go to fotor.com 

-> ABP is disabled on this page as expected

  1. Click on ABP icon and try to deselect Disable on fotor.com

Observed behaviour

Trying to deselect 'Disable on fotor.com' option through the toolbar reloads the page but does not deselect the option and ABP is still disabled for this web site.
It seems to be happening due to specifying fotor.com instead of www.fotor.com

Expected behaviour

User should be able to deselect this option through the APB tool bar.

Attachments (1)

1032_1406100709_Can_not_deselect_Disable_on_specific_site.png (1.1 MB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (8)

comment:1 Changed 5 years ago by passbrains

1 - 23 Jul 2014 09:34:30 posted by Philip Hill
This works fine with eg Chrome.

comment:2 Changed 5 years ago by oleksandr

  • Cc oleksandr@… added
  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

comment:3 Changed 4 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.4

comment:4 Changed 4 years ago by sergz

  • Owner set to sergz

comment:5 Changed 4 years ago by sergz

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 4 years ago by sergz

  • Review URL(s) modified (diff)

comment:7 Changed 4 years ago by sergz

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.