Opened 5 years ago

Closed 4 years ago

#1115 closed defect (fixed)

Some yahoo page not correctly shown on IE8 when ABP enabled

Reported by: passbrains Assignee: sergz
Priority: P2 Milestone: Adblock-Plus-for-Internet-Explorer-1.5
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr, arthur Blocked By: #1699
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5921969115496448/

Description (last modified by philll)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AIN-23

Environment

Windows 7 64bit Internet Explorer 8 English
ABP version 1.2.636.0

How to reproduce

  1. ABP is enabled for IE.
  2. Launch https://uk.eurosport.yahoo.com/snooker website.

Observed behaviour

Links and images are all distorted.

Expected behaviour

Page should be load properly

Attachments (2)

1618_1406118835_ABP.PNG (181.7 KB) - added by passbrains 5 years ago.
1618_1406118836_No_ABP.PNG (388.7 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (13)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 23 Jul 2014 12:51:20 posted by Philip Hill
I am pretty certain that you did not use the latest dev build but instead an older one. As you posted the download URL as version number, i so far cannot prove it. So first, please FOR ALL YOUR REPORTS learn how to find the version number of your Adblock Plus installation (See "Other Notes:" section in test description) and second of all ensure to get the latest version at least daily.

2 - 23 Jul 2014 12:58:45 posted by Philip Hill
Okay, after reproducing this myself, I found that IE 8 still shows the buggy behaviour, while IE 11 after https://issues.adblockplus.org/ticket/270 works well.

comment:2 Changed 5 years ago by philll

  • Description modified (diff)
  • Summary changed from Some yahoo page not correctly shown on IE when ABP enabled to Some yahoo page not correctly shown on IE8 when ABP enabled

comment:3 Changed 5 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Priority changed from Unknown to P2
  • Ready set

comment:4 Changed 5 years ago by sergz

  • Owner set to sergz

comment:5 Changed 5 years ago by sergz

  • Blocked By 1699 added

comment:6 Changed 5 years ago by sergz

The trouble is that the style sheet is blocked. The ACCEPT header in IE8 is */*, so we cannot derive mime type from it and we should try to fallback to use URL, which is
https://s1.yimg.com/zz/combo?d/lib/yui/3.4.1/build/cssreset/cssreset-min.css&d/lib/yui/3.4.1/build/cssfonts/cssfonts-min.css&os/mit/media/p/presentation/grids/master-min-a143923.css&os/mit/media/p/presentation/grids/desktop-min-8723999.css&os/mit/media/p/presentation/base/master-min-8723999.css&os/mit/media/p/presentation/base/desktop-min-a143923.css&os/mit/media/m/header/header-desktop-min-7783740.css&os/mit/media/m/ads/ads-min-81b3fea.css&os/mit/media/m/navigation/navigation-desktop-min-a8a04a0.css&os/mit/media/m/heading/heading-min-1652721.css&os/mit/media/m/footer/footer_sponsor-min-66303b2.css&os/mit/media/m/footer/footer_links-min-66303b2.css&os/mit/media/m/linkbox/linkbox-min-248956.css&os/mit/media/m/footer/footer_info-min-66303b2.css&os/mit/media/m/footer/footer_info-desktop-min-43b1bcf.css

The path is /zz/combo (see WBPassthruSink::GetContentTypeFromURL) and it does not contain anything about CSS, it seems the server script which glues specified CSS in query string into one.

comment:7 Changed 5 years ago by sergz

  • Cc oleksandr arthur added

If we cannot detect the content type from path then we could try with the query string. Although I'm not sure whether it makes sense to analyze query string of the URL because

  • for the site makers it's very easy to modify it
  • we can wrongly interpret it

Split it into parameters and find let's say the first parameter which has some known extension, like ccs, js, swf. What do you think?

One may check the code here http://codereview.adblockplus.org/5921969115496448/

comment:8 Changed 5 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-Next

comment:10 Changed 5 years ago by sergz

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:11 Changed 4 years ago by sergz

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.