Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1122 closed defect (fixed)

ABP stops element selection after cancel button was clicked in the 'Add Filer(s)?' popup

Reported by: passbrains Assignee: saroyanm
Priority: P2 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6275291261435904/

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-13

Environment

Windows 7 64bit Chrome English
ABP version 1.8.3.1204

How to reproduce

  1. Go to http://timesofindia.indiatimes.com/ or http://maanimo.com/
  2. Click ABP icon and select "Block element" option
  3. Select any blockable element on the page
  4. Click Cancel button in the "Add Filer(s)?" dialog
  5. Try selecting other elements
  6. Click ABP icon again

Observed behavior

The bubble UI indicates that you are still in "Block element" mode (you have to click "Cancel"). However, you can't select another element from the page.

Expected behavior

When clicking "Cancel" in the "Add Filer(s)?" dialog, the bubble should leave "Block element" mode, returning to its initial state.

Attachments (1)

207_1406093612_BlockElement.jpg (506.4 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (10)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by sebastian

  • Description modified (diff)

Manually copied description from passbrains. It were truncated due to #1275.

comment:2 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

In fact, I can't reproduce it on http://timesofindia.indiatimes.com/, but on http://maanimo.com/.

comment:3 Changed 5 years ago by saroyanm

  • Owner set to saroyanm

comment:4 Changed 5 years ago by saroyanm

This issue is appears because "page.sendMessage" method which in case of Chrome uses chrome.tabs.sendMessage API, is sending the message to all content scripts of the page which also include content scripts loaded into iframes, in include.postload we change the state of clickHide_activated boolean variable (which indicates whether we should show cancel button for block dialog in popup) after closing block dialog only in the content script of frame where it's loaded, looks like the top frame and so in the popup.js after calling "page.sendMessage" with type of get-clickhide-state we always getting the state of clickHide_activated variable of random content script in the page, so most likely that this issue will persist on pages that contains lot of iframes.

Version 0, edited 5 years ago by saroyanm (next)

comment:5 Changed 5 years ago by saroyanm

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by sebastian

  • Priority changed from P3 to P2

With the current devbuild this happens on all websites when you have used "Block element".

comment:8 Changed 5 years ago by saroyanm

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:9 Changed 5 years ago by saroyanm

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
Note: See TracTickets for help on using tickets.