Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1133 closed defect (fixed)

Sharing on Twitter and Google doesn't work

Reported by: passbrains Assignee: greiner
Priority: P2 Milestone: Adblock-Plus-2.6.5-for-Firefox
Module: User-Interface Keywords:
Cc: Blocked By:
Blocking: Platform: Firefox
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5160622694072320/

Description (last modified by greiner)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-2

Environment

Windows 7 32bit Opera English
ABP version Version 1.8.3.1204

How to reproduce

  1. Install ABP extension on Opera
  2. When "Adblock Plus has been installed" page opens click Twitter or Google button
  3. When "Think Adblock Plus is worth sharing?" window opens observe it and click Twitter icon

Observed behaviour

When click Twitter button on "Adblock Plus has been installed" page, "Think Adblock Plus is worth sharing?" window opens, but clicking Twitter icon here does nothing. Adblock sharing on Twitter and Google doesn't work.

Expected behaviour

Adblock Twitter page should open.

Attachments (2)

2315_1406046695_Sharing_on_Twitter_and_Google_doesnt_work.avi (2.1 MB) - added by passbrains 5 years ago.
2315_1406046695_7-22-2014_7-27-56_PM.jpg (197.0 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (11)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 24 Jul 2014 10:56:42 posted by Abhinav Sejpal
Hi Alexey, I am able to replicate this issue however Please update the replication steps,
you should apply following settings :-

  • Malware Blocking
  • Remove Social Media Buttons
  • Disable Tracking

Thanks for Video POC.

comment:2 Changed 5 years ago by greiner

  • Description modified (diff)

Previously, this issue has been taken care of in https://hg.adblockplus.org/adblockplus/rev/f37b9e53d4e7 and https://hg.adblockplus.org/adblockplus/rev/7d3832ef378d due to "Remove social media buttons" preventing the correct display of our social media buttons.

Currently, we are checking whether the respective scripts are blocked to determine whether the fallback should be applied instead of opening the popup. However, the resources for Twitter and Google+ don't appear to be blocked anymore which is why this issue has now resurfaced.

Last edited 5 years ago by greiner (previous) (diff)

comment:3 Changed 5 years ago by greiner

  • Component changed from Unknown to User-Interface
  • Priority changed from Unknown to P2

comment:4 Changed 5 years ago by saroyanm

Works for me with ABP V 1.8.3.1204.
While I could reproduce the issue with ABP stable (V 1.8.3).

comment:5 Changed 5 years ago by greiner

  • Owner set to greiner

comment:6 Changed 5 years ago by greiner

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 5 years ago by greiner

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:8 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
  • Platform changed from Opera to Firefox/Firefox Mobile
  • Ready set

comment:9 Changed 4 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.