Opened 5 years ago

Closed 5 years ago

#1168 closed defect (rejected)

Android app does not block ads on Puffin Browser

Reported by: Fandroid Assignee:
Priority: Unknown Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Android 4.4.4
Puffin Browser 3.7.1.504
Adblock Plus 1.2.1 build 318
EasyList

How to reproduce

  1. Enable filtering on Adblock
  2. Refresh EasyList
  3. Uncheck acceptable ads
  4. Launch Puffin Browser
  5. Navigate to http://forum.xda-developers.com/showthread.php?t=2390147
  6. Ads still show

Observed behaviour

Ads are blocked on Chrome, just doesn't work on Puffin.

Expected behaviour

Ads should not appear.

Change History (3)

comment:1 Changed 5 years ago by mapx

  • Cc mapx added
  • Component changed from Unknown to Adblock-Plus-for-Android

a comment from the forum:

I think it wont run on puffin because puffin is runing like virtual machine and it s not directly data streamed on android like other browsers so adblock cant detect it.i think that that is the reason but i may be wrong.

https://adblockplus.org/forum/viewtopic.php?f=15&t=24124

Last edited 5 years ago by mapx (previous) (diff)

comment:2 Changed 5 years ago by rjeschke

Yes, as one can see from their official web page, Puffin uses their own network and tunnels traffic, we can't do anything here.

Quote from Puffin's FAQ:

18. Q: Does Puffin support any content-filtering features?
Puffin does not support content-filtering at this moment. If you currently use 3rd party’s content-filtering service, Puffin will bypass the service.

comment:3 Changed 5 years ago by rjeschke

  • Ready set
  • Resolution set to rejected
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.