Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1190 closed defect (incomplete)

codereview.adblockplus.org blanks out if logged in; visible when not logged in

Reported by: famlam Assignee:
Priority: P2 Milestone:
Module: Infrastructure Keywords:
Cc: fhd, fred, mapx, mathias@…, trev Blocked By: #2182
Blocking: Platform: Unknown
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

FF, Chrome, probably all browsers

How to reproduce

  1. Go to (for example) http://codereview.adblockplus.org/6202981292703744/ (as a guest user, thus not logged in)
  2. Log in (with some non-special account, such as mine)
  3. Get a white screen

Observed behaviour

After logging in, no content is shown anymore

Expected behaviour

I would expect to get at least the same view as when I'm anonymous (e.g., guest)

Attachments (2)

loggedin.png (19.3 KB) - added by famlam 5 years ago.
After logging in
notloggedin.png (91.6 KB) - added by famlam 5 years ago.
Before logging in

Download all attachments as: .zip

Change History (17)

Changed 5 years ago by famlam

After logging in

Changed 5 years ago by famlam

Before logging in

comment:1 Changed 5 years ago by mapx

  • Cc mapx added

I don't have an account, but if I try to log in (using my gmail account), I get
"Access not possible" message and then the page is blank even refreshing it.

There is no difference keeping ABP on/off

I noted that when I want to log in a new cookie is created:
ACSID

Deleting ACSID all is ok again.

comment:2 Changed 5 years ago by mapx

  • Priority changed from Unknown to P2

comment:3 Changed 5 years ago by mapx

  • Component changed from Unknown to Infrastructure

comment:4 Changed 5 years ago by matze

Hi there! I cannot reproduce the behavior, neither in Firefox nor using Chrome. Can you please confirm that the issue still exists and, if so, provide more information about your setup? E.g. operating system, browser versions, installed extensions beside ABP, etc.

comment:5 Changed 5 years ago by matze

  • Cc mathias@… added

comment:6 Changed 5 years ago by mapx

yep, still bad for me.

windows xp sp 3

Tested again in 3 browsers:

FF 31
chrome 36
chrome 38

ABP disabled for the site, ABP completely disabled, no difference
(or I disabled all the extensions in chrome 38)

steps:
go to
http://codereview.adblockplus.org/all
click sign in
choose a gmail account
the address now is: http://codereview.adblockplus.org/a/adblockplus.org?continue=/all
the page has only this message: "Access not possible"
try to go to the first link: http://codereview.adblockplus.org/all
the page is completely blank

if I will delete the ACSID cookie the page will load correctly

comment:7 Changed 5 years ago by matze

Thank you, I'll try again!

comment:8 Changed 5 years ago by matze

Still wasn't able to reproduce this on my system (Debian "jessie", various Browsers). I've also tried virtual machines with Windows (XP, 7), without success.

I thought it may be related to some different account type (regarding my GMail accounts association with ABP), and thus created a new GMail account for testing purpose. With this account I am in fact able to reproduce the issue, with any browser or system, just as you've expected.

Since I do not administer either the issue tracker or our Google accounts, I'll assign this ticket to Wladimir.

comment:9 Changed 5 years ago by mapx

  • Owner set to trev

comment:10 Changed 5 years ago by trev

  • Owner trev deleted

@matze: It's generally not a good idea to assign things to people. In our issue tracker the assignee field means "I am working on it right now," not "I should work on it when I have time."

comment:11 Changed 5 years ago by trev

  • Resolution set to invalid
  • Status changed from new to closed

Thing is, there is absolutely nothing I can do about this issue. We cannot do anything about codereview.adblockplus.org, it runs on Google servers and there is no configuration whatsoever. It's also pretty badly maintained. That's one reason why #51 exists.

Resolving as invalid since this isn't our infrastructure...

comment:12 Changed 5 years ago by trev

  • Cc trev added

@famlam: Did you consider the possibility that codereview.adblockplus.org simply had a blackout when you tried to access it and it had nothing to do with the fact that you were logged in? That server really isn't very reliable.

comment:13 Changed 5 years ago by famlam

@trev: 100% reproducible

comment:14 Changed 4 years ago by matze

  • Blocked By 2182 added
  • Cc fhd fred added

Update: @fred has the exact same issue, with his very own *@eyeo.com account. Also, @fhd and I have re-prioritized the migration to a self-hosted setup (see #2182), so that this ticket here should finally become solved (or rather obsolete) in the very near future.

Last edited 4 years ago by matze (previous) (diff)

comment:15 Changed 4 years ago by fred

I changed the primary e-mail address of my Google account to be my @adblockplus.org address (frederik@…) and tried to sign-in to Rietveld again.
This time it worked. Then I changed it back to @eyeo.com, tried again, got the "Access not possible" message again.
So it looks to me as if the access is restricted to the adblockplus.org domain.

Note: See TracTickets for help on using tickets.