Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1192 closed defect (rejected)

"Disable on this page only" applies to all YouTube videos

Reported by: Gingerbread Man Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Firefox Keywords:
Cc: mapx, trev Blocked By:
Blocking: Platform: Firefox
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Firefox 31.0 • Adblock Plus 2.6.4

How to reproduce

  1. Go to literally any YouTube video, e.g. https://www.youtube.com/watch?v=ljWcpj8N6ws
  2. Click the Adblock Plus icon and choose "Disable on this page only".

Observed behavior

The following whitelist filter is added, which applies to all YouTube videos, not just that particular page.
@@|https://www.youtube.com/watch?$document

Expected behavior

The following whitelist filter should be added instead, so that it only applies to that particular page.
@@|https://www.youtube.com/watch?v=ljWcpj8N6ws$document

Change History (5)

comment:1 Changed 5 years ago by mapx

  • Cc mapx added

comment:2 Changed 5 years ago by barbaz

nvm

Last edited 5 years ago by barbaz (previous) (diff)

comment:3 Changed 5 years ago by barbaz

I'm not an ABP developer but I see two problems with this:
1) You shouldn't assume that the v parameter is always first...
2) Sometimes it's better to disable on a page independent of URL parameters. To work around this maybe there could be a separate menu item, or an about:config preference which specifies whether "Disable on this page only" should strip URL parameters.

Also, shouldn't the expected filter be more like
@@|https://www.youtube.com/watch?v=ljWcpj8N6ws^$document
to get closer to the desired restriction of either character & or end of address after the v parameter?

comment:4 Changed 5 years ago by trev

  • Cc trev added
  • Resolution set to rejected
  • Status changed from new to closed

Indeed, this is by design - normally, "this page" should really mean "this page", regardless of any parameters. The fact that the concept doesn't quite work for YouTube merely reflects the fact that defining a page is hard given dynamic websites. Still, I am convinced that YouTube's is a rare scenario and removing parameters does more good than harm. In the long term, we probably want to remove that option altogether and only keep per-domain whitelisting which is less confusing.

comment:5 Changed 5 years ago by philll

  • Platform changed from Firefox/Firefox Mobile to Firefox

Made Firefox and Firefox mobile available as seperate platforms.

Note: See TracTickets for help on using tickets.