Opened 5 years ago

Closed 19 months ago

#1198 closed defect (invalid)

If you share your statistics via facebook, you get a german headline and an english description

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Websites Keywords:
Cc: saroyanm, sebastian, greiner Blocked By: #5447
Blocking: Platform: Unknown
Ready: no Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ASA-11

Environment

Chrome/Opera/Safari

How to reproduce

  1. Install ABP
  2. Click at the icon in Safari
  3. Click at Share via Facebook

Observed behaviour

But the headline is in German, text in English

Expected behaviour

That the text is in English OR in German

Attachments (1)

1598_1407588706_abp_desc.png (222.0 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (20)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 12 Aug 2014 13:52:12 posted by Philip Hill
It's not Safari-specific, happens also with Google Chrome.

comment:2 Changed 5 years ago by philll

  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 5 years ago by saroyanm

The description part of facebook share dialog is being taken from "https://adblockplus.org/".
So I can see 3 solutions here:

  1. Use description from web locale meta (14 Languages), detect language and use url for appropriate language (ex.: https://adblockplus.org/de/).
  2. Add share dialog description to ABP locales and load that description from ABP (48 locales).
  3. Use only English text (which I don't think we want here).

Not sure which is more preferable.

With 1-st solution I've noticed problem that even when using localized sharing link the description is always in English, not yet sure the case, this something connected to website itself, so for example if "https://adblockplus.org/de/chrome" url is being added to the post in FB, it's always shows English text not sure if it's a bug or feature. Also in case of 1-st solution we don't have all ABP translations for website.

Last edited 5 years ago by saroyanm (previous) (diff)

comment:4 Changed 5 years ago by saroyanm

  • Cc manvel@… added

comment:5 follow-ups: Changed 5 years ago by sebastian

I think it makes sense to have Facebook use the title and description from the metadata on our website, and to fix those if necessary.

Consider that the FB button inside the extension's bubble UI, isn't the only way to share ablockplus.org on Facebook. So we should make sure that those metadata are correct and complete.

Or do I miss something here?

comment:6 Changed 5 years ago by sebastian

  • Cc saroyanm sebastian added; manvel@… removed

comment:7 in reply to: ↑ 5 Changed 5 years ago by saroyanm

Replying to sebastian:

I think it makes sense to have Facebook use the title and description from the metadata on our website, and to fix those if necessary.

Yes anyway it make sense to fix the metadata because if you will try to share for example current link https://adblockplus.org/de/chrome post description is in English again, while we have correct metadata in German version of the website, so not sure why it takes again English text from https://adblockplus.org/en/chrome.
I think we need to create another ticket for website fix.
And maybe after fix we will need to generate correct link according to the platform language and use English link for the missing website languages.

comment:8 Changed 5 years ago by saroyanm

  • Blocked By 1274 added

comment:9 in reply to: ↑ 5 Changed 5 years ago by saroyanm

Replying to sebastian:
I've created another ticket for fixing metadata issue in website:
https://issues.adblockplus.org/ticket/1274

comment:10 Changed 5 years ago by sebastian

Thanks. I was just about to do it myself. :)

comment:11 Changed 5 years ago by sebastian

  • Component changed from Unknown to User-Interface
  • Description modified (diff)
  • Platform changed from Safari to Unknown
  • Priority changed from P2 to P3

comment:12 Changed 5 years ago by greiner

  • Cc greiner added

comment:13 Changed 2 years ago by juliandoucette

  • Blocked By 5447 added; 1274 removed
  • Tester set to Unknown

This bug should be fixed by #5447.

comment:14 follow-up: Changed 2 years ago by juliandoucette

Scratch that. It looks like the locale is not being sent to adblockplus.org. Can you look into this greiner?

comment:15 in reply to: ↑ 14 Changed 2 years ago by greiner

Replying to juliandoucette:

Scratch that. It looks like the locale is not being sent to adblockplus.org. Can you look into this greiner?

I guess you're referring to the fb_locale query string parameter?! Because their documentation mentions

When Facebook needs to render an object in one of the specified locales, we will make a request to the object URL with the fb_locale URL parameter set, e.g. &fb_locale=es_ES. The app should then return the object markup in that specified locale.

If so, it sounds like we'd have to handle this parameter in our server-side routing logic because https://adblockplus.org/?fb_locale=de_DE currently returns the English version.

comment:16 Changed 20 months ago by agiammarchi

We are removing share stats https://issues.adblockplus.org/ticket/5613 so I wonder if this ticket makes sense now.

comment:17 Changed 20 months ago by greiner

  • Component changed from User-Interface to Websites
  • Priority changed from P3 to Unknown
  • Ready unset

It's indeed no longer a concern for UI since we're going to remove share functionality from both the icon popup as well as the first-run page.

The underlying issue still remains though. Facebook's crawler will fetch the English version of the page whenever someone shares a link to adblockplus.org. Therefore I'll set the module to Websites.

comment:18 Changed 19 months ago by juliandoucette

I believe that the websites part of this issue was resolved by #5683?

comment:19 Changed 19 months ago by greiner

  • Resolution set to invalid
  • Status changed from new to closed

Indeed sounds like there's nothing to do anymore. I'm closing it as "invalid" then.

Note: See TracTickets for help on using tickets.