Opened 5 years ago

Closed 4 years ago

#1201 closed defect (fixed)

Enabling/disabling ABP everywhere applies only in the next opened tab

Reported by: philll Assignee: oleksandr
Priority: P2 Milestone: Adblock-Plus-for-Internet-Explorer-1.5
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr Blocked By:
Blocking: #1728, #2230 Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5168444685156352/

Description (last modified by oleksandr)

Environment

Win 7 32 bit
Testes in IE 8,9,11
ABP 1.2
Easylist Germany & Easylist
Acceptable ads enabled

How to reproduce

  1. Go to http://www.heise.de/
  2. Watch out for some not blocked image ad in the right column
  3. Click the ABP button
  4. Disable blocking everywhere
  5. Reload the tab with heise.de

Observed behaviour

The ads are still blocked

Expected behaviour

The ad should not be blocked/hidden.

Change History (10)

comment:1 Changed 4 years ago by sergz

  • Owner set to sergz

Despite I cannot reproduce it on http://www.heise.de/, may be we need to find another web site or create some synthetic page for tests, there is the possibility for such behaviour.

When the user refreshes the page the before navigate is not fired and we don't reload filters. Thus the traverser which is called on download complete as well as css injector which is called on document ready state complete use the obsolete filters.

The first time (start page is about:blank) it takes about 150 msec to get element hiding selectors, other times it takes about 75 msec (+/- 10 msec). So I would suppose firstly reload them each time we are going to use them and only afterward if it hurts we can make some optimization as another issue.

comment:2 Changed 4 years ago by sergz

  • Owner sergz deleted

I will come back after finishing with injecting of CSS because it highly depends on the code of css injection as well as it will be better visible how to do it.

comment:3 Changed 4 years ago by oleksandr

  • Cc oleksandr added

comment:4 Changed 4 years ago by oleksandr

  • Blocking 1728 added

comment:5 Changed 4 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-Next

comment:6 Changed 4 years ago by oleksandr

  • Owner set to oleksandr
  • Summary changed from setting changes in ABP for IE don't apply when reloading, but in other tabs to Enabling/disabling ABP everywhere applies only in the next opened tab

comment:7 Changed 4 years ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:8 Changed 4 years ago by oleksandr

  • Description modified (diff)

comment:9 Changed 4 years ago by oleksandr

  • Blocking 2230 added

comment:10 Changed 4 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.