Opened 5 years ago

Closed 5 years ago

#1229 closed defect (rejected)

MSI compression is suboptimal

Reported by: trev Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Internet-Explorer Keywords: installer
Cc: eric@…, oleksandr Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by trev)

How to reproduce

  1. Download https://downloads.adblockplus.org/adblockplusie-1.2-x64.msi
  2. Note the file size (4.558.848 bytes).
  3. Now compress that file, e.g. via gzip adblockplusie-1.2-x64.msi
  4. Look at the file size of the compressed file.

Observed behaviour

The size of the compressed file is 3.218.239 bytes, roughly 70% of the original size. This indicates that the compression of our MSI file is very suboptimal - if it is compressed at all. These MSI files are being downloaded for updates and end up wasting lots of bandwidth if they aren't compressed properly.

Expected behaviour

The size of the compressed file should only be minimally smaller, if at all. Note that adblockplusie-1.2.exe apparently applies additional compression - gzip almost doesn't compress it, and its size is only minimally larger than the two MSI files after they have been compressed by gzip.

Change History (4)

comment:1 Changed 5 years ago by trev

  • Description modified (diff)

comment:2 Changed 5 years ago by trev

Additional info: the cab1.cab file inside adblockplusie-1.2-x64.msi (that's the files actually being installed) is merely 2.594.567 bytes and compressed properly. It seems that the package contains 2 MB of additional uncompressed data, not sure what it is.

comment:3 Changed 5 years ago by trev

  • Platform changed from Unknown to Internet Explorer
  • Ready set

comment:4 Changed 5 years ago by oleksandr

  • Resolution set to rejected
  • Status changed from new to closed

As of 1.4 the size of adblockplusie-FINAL-x64.msi is 4.820.992 bytes. Of those 1.744.896 bytes are transforms that we need to support multiple languages. 2.768.997 bytes is the size of compressed cab1.cab. That leaves just 307.099 bytes for the MSI itself, which is reasonable, I think.

I assume the reason for suboptimal compression is multiple transforms that we are applying, but there's currently no way around that. So this probably won't fix.

Note: See TracTickets for help on using tickets.