Opened 5 years ago

Closed 5 years ago

#1238 closed defect (incomplete)

ABP 1.2 for IE - back button does not work

Reported by: mapx Assignee: sergz
Priority: P2 Milestone:
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr@… Blocked By: #1264
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by mapx)

back button does not work

Environment

IE8, IE10, ABP 1.2

How to reproduce

for example: google.com, then cnn.com
press back button ==> the page is still cnn.com

Change History (7)

comment:1 Changed 5 years ago by mapx

  • Description modified (diff)

comment:2 Changed 5 years ago by philll

  • Priority changed from P2 to P1
  • Ready set

Also in IE11 with ABP 1.2.705. If you click the back button multiple times, it works some times.

comment:3 Changed 5 years ago by oleksandr

  • Cc oleksandr removed
  • Owner set to sergz

comment:4 Changed 5 years ago by oleksandr

  • Blocked By 1264 added

comment:5 Changed 5 years ago by oleksandr

  • Cc oleksandr@… added
  • Priority changed from P1 to P2

comment:6 Changed 5 years ago by sergz

In IE8 http://msdn.microsoft.com/en-us/library/aa767876(v=vs.85).aspx is even not called, I've googled these addresses which are added to the navigation history (static.ak.facebook.com/connect/xd_arbiter) and discovered a lot of reports about that issue in IE8-10, so it might be not our issue. I've configured virtual machine to be very slow and disabled our addon and still can reproduce the issue. I don't know how it happens exactly. Basically it looks like it can happen not only with facebook. One can find when iframe breaks back button in IE.

steps to reproduce

The environment should be very very slow It's very hard to get it on the fast machine.

  • open cnn.com
  • click somewhere, for example, Africa
  • navigate back
  • check back button dropdown menu

comment:7 Changed 5 years ago by oleksandr

  • Resolution set to invalid
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.