Opened 5 years ago

Closed 5 years ago

#1272 closed defect (duplicate)

Request blocking is active on options and first run page leading to JavaScript errors

Reported by: sebastian Assignee: sebastian
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Safari

How to reproduce

  1. Click on the ABP logo in order to open the bubble UI
  2. Click on "Options"
  3. Look at the JavaScript Console (Cmd + Option + C)

Observed behaviour

You see an error saying Can't find variable: relativeToAbsoluteUrl. That is because that function is called by the request blocking code. But the function is defined in include.preload.js which isn't loaded here.

Expected behaviour

There shouldn't be any errors in the JavaScript console.

Change History (3)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Ready set

comment:3 Changed 5 years ago by sebastian

  • Resolution set to duplicate
  • Review URL(s) modified (diff)
  • Status changed from reviewing to closed

With #1801, relativeToAbsoluteUrl() will no longer be used here.

Note: See TracTickets for help on using tickets.