Changes between Version 1 and Version 3 of Ticket #1273


Ignore:
Timestamp:
08/27/2014 01:57:23 PM (5 years ago)
Author:
sebastian
Comment:

https://hg.adblockplus.org/adblockplus/rev/10df3dfad74f https://hg.adblockplus.org/adblockpluschrome/rev/e7a439a7f672

Legend:

Unmodified
Added
Removed
Modified
  • Ticket #1273

    • Property Status changed from reviewing to closed
    • Property Resolution changed from to fixed
    • Property Summary changed from WebKit misoptimazions strike again: Overridden getters are called on Safari 8 to WebKit misoptimizations strike again: Overridden getters are called on Safari 8
    • Property Priority changed from P2 to P1
    • Property Milestone changed from to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Ticket #1273 – Description

    v1 v3  
    55Randomly, some ads aren't blocked, while the log of the global page is flooded with errors indicating that the readonly properties `RegExpFilter.regexp` and `ActiveFilter.domains` are attempted to be redefined. 
    66 
    7 The reason is [https://bugs.webkit.org/show_bug.cgi?id=132872 WebKit bug 132872], which we previously worked around with #419. However it seems that Safari 8 does more aggressive optimazions, rendering our current workaround insufficient. 
     7The reason is [https://bugs.webkit.org/show_bug.cgi?id=132872 WebKit bug 132872], which we previously worked around with #419. However it seems that Safari 8 does more aggressive optimizations, rendering our current workaround insufficient. 
    88 
    99=== Expected behaviour === 
    10 Ads should be always blocked when Adblock Plus is active.  No unhandled JavaScript errors should occur in the global page. 
     10Ads should be always blocked when Adblock Plus is active.  No unhandled JavaScript errors should occur.