Opened 5 years ago

Closed 5 years ago

#1280 closed change (fixed)

Update v8 to 3.20.16

Reported by: fhd Assignee: sergz
Priority: P2 Milestone:
Module: Libadblockplus Keywords:
Cc: trev, sergz, oleksandr@…, jobp@… Blocked By:
Blocking: #1197 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6584950149087232/

Description (last modified by fhd)

Background

Maxthon needs libadblockplus to work against v8 version 3.20.16.

What to change

Update our v8 clone to version 3.20.16 - this will probably require various changes in libadblockplus to keep up with API changes.

Change History (17)

comment:1 Changed 5 years ago by fhd

  • Blocking 1197 added

comment:2 Changed 5 years ago by trev

  • Cc trev sergz added

comment:3 Changed 5 years ago by oleksandr

  • Cc oleksandr@… added

comment:4 Changed 5 years ago by fhd

  • Priority changed from P3 to P2

Increasing priority, Maxthon will need this.

comment:5 Changed 5 years ago by sergz

  • Owner set to sergz

comment:6 Changed 5 years ago by jobp

Any updates on this? I need to get back to Maxthon with an answer here.

Version 0, edited 5 years ago by jobp (next)

comment:7 Changed 5 years ago by jobp

  • Cc jobp@… added

comment:8 Changed 5 years ago by jobp

  • Sensitive set

comment:9 Changed 5 years ago by jobp

  • Sensitive unset

comment:10 Changed 5 years ago by fhd

Just learned that Maxthon needs V* version 3.20.16 (2013-08-13) specifically, were you aware of that?

comment:11 Changed 5 years ago by oleksandr

  • Blocking 1087 added

comment:12 Changed 5 years ago by sergz

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:13 Changed 5 years ago by sergz

  • Review URL(s) modified (diff)

comment:14 Changed 5 years ago by fhd

  • Description modified (diff)
  • Summary changed from Update v8 to Update v8 to 3.20.16

comment:15 Changed 5 years ago by fhd

  • Blocking 1087 removed

comment:16 Changed 5 years ago by fhd

Made it more specific that this issue is about updating to the version Maxthon needs. There's the slightly older #1197 for updating to the latest version of v8.

comment:17 Changed 5 years ago by sergz

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.