Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1290 closed defect (fixed)

Stylesheets aren't injected with Shadow DOM anymore

Reported by: sebastian Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.5-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5978149049335808

Description (last modified by sebastian)

Environment

Chrome 37

How to reproduce

  1. Visit any website
  2. Inspect the page (Ctrl + Shift + I)

Observed behaviour

You see the stylesheet Adblock Plus injected into the light DOM, bringing back issues like #309 and #369.

That is because since Chrome 36 there is no webkitCreateShadowRoot anymore. However, the un-prefixed createShadowRoot (added in Chrome 35) isn't supported by Adblock Plus yet.

Expected behaviour

The stylesheet should be injected with the Shadow DOM, hiding it from the website's JavaScript.

Change History (4)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Description modified (diff)
  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 5 years ago by sebastian

  • Summary changed from Stylesheets aren't injected with Shadow DOM anymore on Chrome 37 to Stylesheets aren't injected with Shadow DOM anymore

comment:4 Changed 5 years ago by trev

  • Milestone changed from Adblock-Plus-for-Chrome-Opera-Safari-1.8.4 to Adblock-Plus-for-Chrome-Opera-Safari-next
Note: See TracTickets for help on using tickets.