Opened 5 years ago

Closed 5 years ago

#1323 closed defect (duplicate)

Blocked elements counter increases without stopping

Reported by: Gingerbread Man Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Chrome 37.0.2062.102 m • Adblock Plus 1.8.4.1218 • EasyList • Adblock Warning Removal List
Opera 23.0.1522.77 • Adblock Plus 1.8.4.1218 • EasyList • Adblock Warning Removal List

How to reproduce

  1. With the above subscriptions enabled and no others, load
  1. Disable Adblock Warning Removal List, then reload the pages.

Observed behavior

With Adblock Warning Removal List enabled, the counter of blocked elements increments into infinity.

Expected behavior

The counter of blocked elements should stop counting eventually.

Notes

This issue appeared resolved for a while. At the time, I could only reproduce it with ABP 1.8.3, EasyList and Malware Domains. There was no problem with same subscriptions with the development build (presumably ABP 1.8.3.1211 based on when I posted my forum message).

Change History (7)

comment:1 Changed 5 years ago by Gingerbread Man

EasyList was updated, so now in order to reproduce the issue, you have to disable EasyList and manually add the blocking filters:

sillyvamp.com

/googleads.
||partner.googleadservices.com^$third-party
||projectwonderful.com^$third-party
.com/ads/$image,object,subdocument

davescomputertips.com

||amazon-adsystem.com^$third-party
||media6degrees.com^$third-party
||tqlkg.com^$third-party

Also note that whitelists related to the ad counter date back at least 5 months. It would be far preferable if the underlying issue was fixed, especially since whitelists affect browsers that don't have this problem.

comment:2 Changed 5 years ago by Gingerbread Man

Now it's happening with cheathappens.com

Again, I see no problem if I disable Malware Domains. It's currently blocking the whole domain.

comment:3 Changed 5 years ago by Gingerbread Man

Someone reported this on http://www.velominati.com/the-rules/
I don't have access to a Mac, so I can't test Safari, but I couldn't reproduce it in Opera.

comment:4 follow-up: Changed 5 years ago by Gingerbread Man

livescience.com, triggered by Fanboy's Annoyances / Social Blocking List.
https://adblockplus.org/forum/viewtopic.php?p=106762#p106762

Problematic filter:

/social/footer_

Could be solved by making the existing whitelist filter a bit more permissive:

@@||livescience.com/images/site/social/footer_buttons.gif
@@||livescience.com/images/site/social/footer_*.gif

zvv.ch and vidin.ru were both reported, but I couldn't reproduce either.
https://adblockplus.org/forum/viewtopic.php?p=106415#p106415
https://adblockplus.org/forum/viewtopic.php?p=106729#p106729

comment:5 Changed 5 years ago by philll

See also #1396

comment:6 in reply to: ↑ 4 Changed 5 years ago by Gingerbread Man

Replying to Gingerbread Man:

livescience.com, triggered by Fanboy's Annoyances / Social Blocking List.

Fanboy fixed it.

comment:7 Changed 5 years ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

Seems to be fixed by #1396.

Note: See TracTickets for help on using tickets.