Opened 5 years ago

Closed 5 years ago

#1325 closed defect (fixed)

After you canceled blocking an element there are still color marks of it

Reported by: passbrains Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.6-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: saroyanm Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5455501458407424

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-32

Environment

Mac OS X 10.8 Opera German
ABP version 1.8.3.1207

How to reproduce

  1. Install ABP
  2. Open for example http://www.dict.cc/?s=ausnahmen
  3. Choose "Block an element"
  4. Click through the site
  5. Click "Cancel" in the bubble

Observed behaviour

It has still color marks of element blocking

Expected behaviour

The site will be displayed like it looked before.

Attachments (1)

1598_1409836243_aop_cancel.mp4 (1.0 MB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 02 Sep 2014 09:48:53 posted by Timo Scherf
Hello Claudia,
could you please focus on the Opera browser and reload the page and not switch between Safari and Opera.
Greetings from Passbrains

2 - 04 Sep 2014 07:57:46 posted by Claudia Figura
A file was deleted: abp_op_block.swf

3 - 04 Sep 2014 12:58:22 posted by Sebastian Noack
I can not reproduce that behavior as described above. Also I can not watch the attached screencast. Please don't use flash, but a more portable format like webm, mpeg4, avi or Theora.

4 - 04 Sep 2014 13:10:43 posted by Claudia Figura
A file was deleted: abp_op_cancel.swf

5 - 04 Sep 2014 13:11:10 posted by Claudia Figura
Added a screencast in the right format. Sorry for that!

comment:2 Changed 5 years ago by sebastian

  • Cc saroyanm sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Opera to Unknown
  • Priority changed from Unknown to P3
  • Ready set

Also reproducible on Chrome. Might be related to #1122.

comment:3 Changed 5 years ago by saroyanm

I've looked through the issue and it's looks not related to #1122,
So far what I can reproduce, when you click cancel button in popup the Block Element functionality is being disabled on that page.
Also noticed that the style which is changed during hovering elements in Blocking Element mode enabled is the one what the page is using when onmouseover event is triggered on the row.
So it more looks like that When Block Element is enabled onmouseout event is not triggered on the html element.

Only one concern I have - in the video after canceling Block Element functionality mouse hovers the yellow elements and they were not changing their style to initial state while after clicking cancel button and hovering the elements the styles are changing to their initial states during my reproduction.

comment:4 Changed 5 years ago by sebastian

The problem here is that our mouseout handler is called and restores the previous background color, after their mouseout handler already updated the background color.

I think the best solution would be to use shadow DOM if possible when highlighting elements. Of course this won't work for Safari, and in some scenarios like when the element cannot have a shadow root, or when the element has important inline styles.

Last edited 5 years ago by sebastian (previous) (diff)

comment:5 Changed 5 years ago by sebastian

  • Cc sebastian removed
  • Owner set to sebastian

comment:6 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:7 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.