Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1337 closed defect (fixed)

The installer fails to close IE — at Version 3

Reported by: passbrains Assignee:
Priority: P4 Milestone:
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5643369099296768/
http://codereview.adblockplus.org/5663180676136960/

Description (last modified by oleksandr)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AIN-18

Environment

Windows 7 32bit Internet Explorer 11 English
ABP version 1.2.636.0

How to reproduce

Win 7, 64bit, IE11

  1. Open IE with installed ABP
  2. Run the installer
  3. Answer Yes to 'Would you like to shut down IE'
  4. Answer Yes to 'Would you like the installer to close IE for you'

Observed behaviour

  • After answering Yes nothing happens with IE
  • After a few seconds installer shows 'The installer fails to close IE. Would you like to retry'
  • Clicking retry does not close IE as well

Expected behaviour

User should be able to close IE through the installer.

Change History (3)

comment:1 Changed 5 years ago by passbrains

1 - 25 Jul 2014 12:24:58 posted by Oleksandr Paraska
This should be fixed in version 1.2.667

comment:2 Changed 5 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Description modified (diff)
  • Priority changed from Unknown to P4

Most likely the issue here is that IE is closed, but the iexplore.exe process is still hanging, which makes this a dupplicate of #1336. I can't reproduce any other cases.

comment:3 Changed 5 years ago by oleksandr

  • Resolution set to fixed
  • Review URL(s) modified (diff)
  • Status changed from new to closed
Note: See TracTickets for help on using tickets.