Opened 5 years ago

Closed 4 years ago

#1339 closed defect (fixed)

Page automatically reloads when ABP enabled or disabled by user

Reported by: passbrains Assignee: oleksandr
Priority: P3 Milestone: Adblock-Plus-for-Internet-Explorer-1.5
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: oleksandr@… Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4920381332783104/

Description (last modified by oleksandr)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AIN-48

Environment

none of assigned configurations
ABP version 1.2.684.0

How to reproduce

1.Install ABP add-on on Internet explorer browser
2.After installation, find the ABP icon on sttaus bar on bottom of the page and make sure ABP enabled.
3.Open any website page
(ex: http://australia.ni.com/)

  1. Click on "create a new user account"

5.Enter some random data in to the fields.
6.Now go to ABP icon and select "disable on "lumen.ni.com"
7.Observe that page reloads automatically
8.Observe that after page reload, previously entered data lost.

Test Environment:
Windows 7-64 bit

IE :11

Observed behaviour

Page automatically reloads if ABP is enabled or Disabled by user.

Expected behaviour

Consistent /same functionality (behavior) expected across all browsers.

As per client's comments in  "Ticket # AOP-8",  page should not reload automatically if ABP is enabled /disabled by user.
[comments entered by client in "Ticket # AOP-8" :
This is by design to have the user explicitly decide on page reloads to not accidentally waste data entered into it. ]

Attachments (1)

921_1407369959_IE_pagereloadautomaticallyifABPdisabled_enabled.swf (5.7 MB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (10)

comment:1 Changed 5 years ago by oleksandr

  • Cc oleksandr@… added
  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Description modified (diff)
  • Priority changed from Unknown to P3
  • Ready set

comment:2 Changed 5 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.4

comment:3 Changed 5 years ago by eric@…

Reloading when the plugin is enabled/disabled seems like the correct behavior, not the incorrect one. When ABP is enabled, ads should be blocked; it should not matter that it was _just now_ enabled. This behavior requires reload-on-enable. If this isn't the behavior, we'll get a whole slew of bug reports of the form "I enabled ABP but my ads aren't blocked".

The original complaint is, perhaps, a consequence of inadequate documentation that enabling/disabling causes a reload. This fix would require some kind of notice to the user, perhaps as a tooltip.

Other ways of solving the problem would be to detect changes in form data from first load or to save/restore form data. This first is a lot of work for minimal benefit and the second is of dubious reliability.

comment:4 Changed 5 years ago by oleksandr

  • Owner set to oleksandr

It would only be consistent with other browsers if we did not reload. We didn't seem to get any slew of bug reports there, and we get this one.

comment:5 Changed 5 years ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by sergz

I'm for consistency with the behavior in other browsers, although I personally expect that the page could be reloaded when the plugin becomes enabled/disabled.

comment:7 Changed 5 years ago by oleksandr

The problem here is that if you have multiple tabs open it would mean reloading all of them. I think this can amount to a pretty horrible user experience.

comment:8 Changed 4 years ago by Mailkov

A possible solution for the "multiple tabs problem" is to reload the page only for the current tab and when user has changed tab reload the page.

comment:9 Changed 4 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.