Opened 5 years ago

Closed 5 years ago

#1342 closed defect (incomplete)

ABP option pop-up disappearing is slow

Reported by: passbrains Assignee:
Priority: P5 Milestone:
Module: User-Interface Keywords:
Cc: Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by greiner)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-47

Environment

Windows Vista 64bit Opera English
ABP version Adblock Plus Version 1.8.4.1219

How to reproduce

  1. 1. Install ABP extension on Opera.
  2. Load any website for example

http://www.vahrehvah.com/user/create

  1. Click on  ABP icon (next to url bar).

Pop up will be displayed

  1. Select Block Element option and hover mouse to any element on the page (specially towards right top corner) and wait
  2. Observe Pop up disappearing automatically

 

Observed behaviour

It will take more than 5 seconds to pop up to go OFF.
This is problamatic if some element is selected towards top right corner where pop-up is on top of item to be blocked.
User needs to atleast 5 seconds which is frustrating.

Expected behaviour

Pop up shall disappear fast (say within 2 seconds).

Attachments (1)

3668_1409937007_performance.jpg (147.3 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (4)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 09 Sep 2014 15:14:57 posted by Philip Hill
Actually more of a change request here (which would be out of scope), but as this annoyed me quite a bit already, I will accept it.

comment:2 Changed 5 years ago by greiner

  • Component changed from Unknown to User-Interface
  • Description modified (diff)
  • Priority changed from Unknown to P5

comment:3 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

It's intended that the popup automatically closes after 5 seconds. It's explicitly configured in our code for as long as the popup UI existed. And nobody complained so far.

However, decreasing that timeout will make it difficult for some users to read the instructions. Also I consider, the case where the element you want to block is covered by the popup, a corner case in which it is fine to wait 5 seconds.

Note: See TracTickets for help on using tickets.