Opened 5 years ago

Closed 5 years ago

#1343 closed defect (duplicate)

"Block Element" suggests wrong URL for Cookery site logo image and thus it does not get blocked

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-46

Environment

Windows Vista 64bit Opera English
ABP version Adblock Plus Version 1.8.4.1219

How to reproduce

  1. 1. Install ABP extension on Opera latest version.
  2. Load page  http://www.vahrehvah.com
  3. Block the logo image by Block Element option as shown in attached image1 by red circle.

Image gets blocked.

  1. Reload the page as in step 2.

Observe image3

Observed behaviour

Logo image does not get blocked.
On reloading the page logo image is present again.

Expected behaviour

Website logo image shall be blocked

Attachments (3)

3668_1409935781_vah-image1.jpg (161.6 KB) - added by passbrains 5 years ago.
3668_1409935781_vah-image2.jpg (163.8 KB) - added by passbrains 5 years ago.
3668_1409935781_vah-image3.jpg (166.3 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 09 Sep 2014 15:35:40 posted by Philip Hill
The actual logo URL is http://4ce2032c9354eeb31dd1-400a7c4969b327f894bac06df18ca698.r76.cf6.rackcdn.com//img/logo.png which differs from the one suggested by the "Block Element" function by one slash: http://4ce2032c9354eeb31dd1-400a7c4969b327f894bac06df18ca698.r76.cf6.rackcdn.com/img/logo.png

Blocking the actual URL perfectly blocks the image. "Block Element" should thereby suggest the correct URL in the first place (Firefox is able to do so).

comment:2 Changed 5 years ago by sebastian

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

That is because subsequent slashes are stripped when Adblock Plus normalizes the URL.

However, the fix that is currently under review for #1393 will also fix this issue.

Note: See TracTickets for help on using tickets.