Opened 5 years ago

Closed 5 years ago

#1344 closed defect (incomplete)

Block element option does not behave consistently on all elements

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by greiner)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-42

Environment

Windows Vista 64bit Opera English
ABP version Adblock Plus Version 1.8.4.1219

How to reproduce

  1. Install latest ABP extension on Opera.

opera version 23.0.1522.77

  1. Launch any website for example : http://www.w3schools.com/tags/tag_a.asp
  2. Hover near top left of the page near w3schools.com link

and right click. You will see "Block Element" option. see image 1.

  1. Hover near other elements on the page for example :

Chrome browser icon in "browser support" table. see image 2.

  1. Select ABP option near right side of url field and click on Block element. and hover near same element as in step 4.  see image3

Observed behaviour

Block element option on right click does not appear consistently.
On the contrary if Block element is enabled by ABP option, then the element specified in step 4 shows yellow highlight for blocking.

Expected behaviour

Block element option on right click shall  appear consistently and behavior shall be in sync if  block element option through ABP icon or right side of url bar.

Attachments (3)

3659_1409855153_w3-image1.jpg (131.0 KB) - added by passbrains 5 years ago.
3659_1409855153_w3-image2.jpg (131.7 KB) - added by passbrains 5 years ago.
3659_1409855153_w3-image3.jpg (112.8 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (6)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 09 Sep 2014 15:44:27 posted by Philip Hill
Although this a change request, as the context menu currently only offers this functionality for a few defined types of elements like images, I accept this to get an official decision on whether this makes sense as compared to the functionality offered via the bubble ui.

comment:2 Changed 5 years ago by greiner

  • Component changed from Unknown to User-Interface
  • Description modified (diff)

comment:3 Changed 5 years ago by sebastian

  • Component changed from User-Interface to Platform
  • Resolution set to invalid
  • Status changed from new to closed

The "Block Element" context menu entry is only created for <img>, <video> and <audio> elements. That makes sense for following reasons:

  1. Those are the only elements that have a mandatory src attribute. So we can always generate a filter for them. Otherwise we would have to determine whether we can generate a filter for the element and update the context menu accordingly every time the user moves the mouse.
  1. In most other cases it wouldn't be clear which element is going to be blocked (the leaf node or any of its ancestors). However, this is obvious when using "Block Element" from the bubble because it highlights the element.
Note: See TracTickets for help on using tickets.