Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1348 closed defect (duplicate)

Blocked tv.com search box element reappears on page refresh

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by kzar)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-54

Environment

Windows Vista 64bit Opera English
(Also Chrome on Mac)
ABP version Adblock Plus Version 1.8.4.1219

How to reproduce

  1. Install ABP extension on Opera.
  2. Loads the website  http://www.tv.com
  3. Block the search box element available on top right.
  4. Refresh the page
  5. Notice the search box has returned

Observed behaviour

The search bar returns on page refresh after being blocked.

Expected behaviour

The search bar would not return after being blocked.

Notes

I first had to block a transparent iframe before being able to block the search box.

Attachments (2)

3659_1410029026_tv-image1.jpg (182.4 KB) - added by passbrains 5 years ago.
3659_1410029026_tv-image2.jpg (172.2 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 09 Sep 2014 14:22:03 posted by Philip Hill
Which filter did you create for blocking this element?

2 - 10 Sep 2014 10:32:26 posted by Dave Barker
I could reproduce this in Chrome on Mac as well. I had to first block the whole screen iframe and then could block the search box. When I then refreshed the search box was displayed again.

3 - 10 Sep 2014 10:36:36 posted by Dave Barker
Rules it added:

www.tv.com###tv_search_head
www.tv.com##.search_text

comment:2 Changed 5 years ago by kzar

  • Description modified (diff)

comment:3 Changed 5 years ago by kzar

  • Summary changed from search box blocked element reappears on hitting BACK to Blocked tv.com search box element reappears on page refresh search box

comment:4 Changed 5 years ago by kzar

  • Summary changed from Blocked tv.com search box element reappears on page refresh search box to Blocked tv.com search box element reappears on page refresh

comment:5 Changed 5 years ago by sebastian

  • Resolution set to duplicate
  • Status changed from new to closed

Blocking the search box actually works fine. However if you first block that overlay, following invalid filter (which misses escaping) is added, and breaks every other element hiding filter in the same chunk, too:

www.tv.com###google_ads_iframe_/8264/aw-tv/home_3

Beside the steps to reproduce are incomplete, this is a duplicate of #1395.

comment:6 Changed 5 years ago by sebastian

The escaping issues have been fixed with #1527.

Note: See TracTickets for help on using tickets.