Opened 5 years ago

Closed 5 years ago

#1349 closed defect (incomplete)

Block element highlighting during selection is sometimes inconsistent

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by kzar)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-22

Environment

Windows 7 64bit Opera English
ABP version 1.8.3.1207
(Also chrome for mac)

How to reproduce

  1. Browse to http://adblockplus.org
  2. Click on the Adblock Plus icon and then click "Block element"
  3. Hover over the items in the adblockplus.org main menu

Observed behaviour

The first button "Installation" can be highlighted yellow but not the other menu items.

Expected behaviour

All of the menu items should be highlighted yellow on mouseover for potentially blocking.

Change History (5)

comment:1 Changed 5 years ago by passbrains

1 - 28 Aug 2014 12:09:42 posted by Sebastian Noack
This is the same issue reported as https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=ACH-13.

2 - 28 Aug 2014 23:50:02 posted by Shailaja Juluru
This issue is different from Ticket# ACH-13.
Can you please go through reproductive steps and video once again ?

Here in this issue, Filter added under add filter window.
After that If I go back to ABP icon,
Cancel option appears instead of block element option.
(Block Element option is expected)

In Ticket ACH# 13,Filter is not added under Add filter window, Cancel pressed on Add filter window.If we go back to ABP icon Cancel option appears(which is expected. But the issue is Element selection is not allowed.

Hope this helps,
Thanks,
Shailaja

3 - 29 Aug 2014 01:51:24 posted by Shailaja Juluru
I have added .mp4 file for your convenience.

Thanks,
Shailaja

comment:2 Changed 5 years ago by kzar

  • Description modified (diff)
  • Summary changed from Cancel option appeared (instead of block element option) after an element is blocked to Block element highlighting during selection is sometimes inconsistent

comment:3 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

That is because the active link has two CSS classes, which result into an element hiding filter. However, the other links don't have any distinct attributes, we could generate a filter from. Therefore it works as expected.

Note: See TracTickets for help on using tickets.