Opened 5 years ago

Closed 5 years ago

#1365 closed defect (fixed)

Development build creation fails if custom "hg log" parameters are configured

Reported by: trev Assignee: trev
Priority: P4 Milestone:
Module: Infrastructure Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/4910232006295552/

Description

How to reproduce

  1. Add the following to your mercurial.ini file:
    [defaults]
    log = -G
    
  2. Run python -m sitescripts.extensions.bin.createNightlies

Observed behaviour

Development build creation fails due to hg log output using an unexpected format (something that the --template parameter was actually supposed to avoid).

Expected behaviour

Development build creation shouldn't be affected by the default parameters.

Change History (2)

comment:1 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.