Opened 5 years ago

Closed 5 years ago

#1366 closed defect (fixed)

ensure_dependencies.py checkout fails for master revision

Reported by: trev Assignee: trev
Priority: P4 Milestone:
Module: Automation Keywords:
Cc: Blocked By:
Blocking: #170, #1369 Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6490407919681536

Description

How to reproduce

  1. Make sure that the dependencies file of a Git repository references the master revision of another repository.
  2. Run ensure_dependencies.py.

Observed behaviour

The dependency is cloned but the directory is empty - no checkout happened. This is because git rev-parse HEAD identifies the current revision as the master revision even though nothing was checked out. This is different from Mercurial that will give you revision 000000000000 in that scenario.

Expected behaviour

Checkout happens and the directory contains all the necessary files.

Change History (4)

comment:1 Changed 5 years ago by trev

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by matze

  • Blocking 1369 added; 170 removed

comment:3 Changed 5 years ago by matze

  • Blocking 170 added

comment:4 Changed 5 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.