Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1368 closed defect (fixed)

System requirements page is outdated [3]

Reported by: Gingerbread Man Assignee: philll
Priority: P1 Milestone:
Module: Websites Keywords: adblockplus.org content
Cc: trev, fhd Blocked By:
Blocking: Platform: Unknown
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

https://adblockplus.org/en/requirements

  • Firefox 32 is the stable release. Firefox 35 is the latest development build.
  • Seamonkey 2.29 is the stable release. Seamonkey 2.32 is the latest development build.

This is the third time I've filed this bug report. Any chance you could keep the page up-to-date in the future? If you like RSS feeds, you can create some out of the relevant release pages at http://www.page2rss.com.

Change History (7)

comment:1 Changed 5 years ago by philll

  • Owner set to philll

comment:2 Changed 5 years ago by philll

  • Cc trev fhd added
  • Priority changed from Unknown to P1
  • Resolution set to fixed
  • Status changed from new to closed

I fixed this consistently for now, however, I will check, whether we can change this to only list minimum versions with a hint to use our dev builds for betas/nightlies in future.

@trev: Please give your opinion on this.

comment:3 Changed 5 years ago by Gingerbread Man

Thank you.

Speaking of minimum versions, what's up with the ones listed on the page? The page lists Firefox 30, Seamonkey 2.27 and Thunderbird 24 as the lowest supported versions. In reality, Adblock Plus currently works with Firefox 22, Seamonkey 2.19 and Thunderbird 22.

comment:4 follow-up: Changed 5 years ago by trev

This is intentional. While technically Adblock Plus still works with Firefox 22, the old versions get too little testing and cannot really be considered supported. Our policy is to support only the current Firefox release and the one before it.

comment:5 Changed 5 years ago by trev

  • Component changed from Infrastructure to Websites

comment:6 in reply to: ↑ 4 Changed 5 years ago by Gingerbread Man

Replying to trev:

This is intentional.

I figured, which is why I didn't put that in the bug report.

While technically Adblock Plus still works with Firefox 22, the old versions get too little
testing and cannot really be considered supported. Our policy is to support only the current
Firefox release and the one before it.

What about ESR? At the moment, it coincidentally happens to be current release -1, but that will soon change. It would be pretty odd to have a subforum dedicated to enterprise use and simultaneously tell such users Adblock Plus isn't supported on their systems.

comment:7 Changed 5 years ago by trev

Yes, at the moment we don't officially support ESR releases - these have too few users (especially too few development build users), which already caused significant issues to go unnoticed in the past. So it's a "use at your own risk" thing.

Note: See TracTickets for help on using tickets.