Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1370 closed defect (fixed)

ABP 1.8.5, chrome 38 (64-bit), postload.js error

Reported by: mapx Assignee:
Priority: P4 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: sebastian Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

https://github.com/adblockplus/adblockpluschrome/pull/7

Description

Environment

windows 7
chrome Version 38.0.2125.58 beta-m (64-bit)
ABP 1.8.5

How to reproduce

go to youtube.com

in the console there is an error:

Uncaught ReferenceError: ext is not defined
chrome-extension://ldcecbkkoecffmfljeihcmifjjdoepkn/include.postload.js:476

the row in error:

ext.onMessage.addListener(function(msg, sender, sendResponse)

Change History (6)

comment:1 Changed 5 years ago by mapx

  • Component changed from Unknown to Platform
  • Platform changed from Unknown to Chrome

comment:2 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Resolution set to invalid
  • Status changed from new to closed

This is a Chrome bug. Content scripts supposed to run at document_start don't run in frames with URLs like javascript:"". Content scripts at document_end run though, leading to that exception.

Also element hiding/collapsing as well as the "Block Element" dialog doesn't work in such frames.

comment:3 Changed 5 years ago by trev

  • Ready set
  • Resolution invalid deleted
  • Status changed from closed to reopened

Reopening since we decided to implement a workaround for now.

comment:4 Changed 5 years ago by trev

  • Priority changed from Unknown to P4
  • Review URL(s) modified (diff)
  • Status changed from reopened to reviewing

comment:5 Changed 5 years ago by trev

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:6 Changed 5 years ago by trev

One more commit to update Chrome version number in the comment (the issue will be fixed in Chrome 41, not Chrome 40 as expected originally):

https://hg.adblockplus.org/adblockpluschrome/rev/9430b640fc04

Approved by Sebastian on IRC.

Note: See TracTickets for help on using tickets.