Opened 3 years ago

Closed 3 years ago

Last modified 3 years ago

#1372 closed defect (fixed)

ABP for Chrome 38 beta doesn't let ESPN videos play

Reported by: philll Assignee:
Priority: P1 Milestone: Adblock-Plus-1.8.6-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: mapx, sebastian, trev Blocked By:
Blocking: Platform: Chrome
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5420918314631168/

Description

Environment

Windows 7 64 bit
Chrome Version 38.0.2125.24 beta-m
ABP 1.8.5.1221

How to reproduce

  1. Open http://espn.go.com/video/clip?id=11524750&categoryid=2378529
  2. Click the play button

Observed behaviour

The video player doesn't play the video. Works with Chrome 36 and the same ABP build.

Expected behaviour

The video should be played, as it does with ABP switched off.

Change History (11)

comment:1 Changed 3 years ago by mapx

with the exceptions the video plays correctly

@@||fwmrm.net/p/espn_live/*.swf
@@||fwmrm.net/crossdomain.xml

Last edited 3 years ago by mapx (previous) (diff)

comment:2 Changed 3 years ago by mapx

  • Cc mapx added

comment:3 Changed 3 years ago by mapx

a similar issue with atresplayer site
in chrome 38 I added some filters to ..unblock requests already whitelisted !

https://adblockplus.org/forum/viewtopic.php?p=106553#p106553

comment:4 Changed 3 years ago by mapx

another report
https://adblockplus.org/forum/viewtopic.php?f=2&t=25093

I have to whitelist elements already ...whitelisted by easylist

Last edited 3 years ago by mapx (previous) (diff)

comment:5 Changed 3 years ago by mapx

  • Cc sebastian added

comment:7 Changed 3 years ago by sebastian

  • Cc trev added
  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P1

I confirm that this issue is caused by that Chrome bug.

The files https://m.v.fwmrm.net/crossdomain.xml and http://adm.fwmrm.net/crossdomain.xml are blocked by following filter in EasyList, preventing further requests to those domains:

||fwmrm.net^$~object-subrequest,third-party

As you can see, this filter is actually limited to non-object requests only. However, with Chrome 38 (Beta) requests that were previously reported with the type object are now reported with the type other. I guess the best we can do here, to work around that bug, would be to consider all requests reported with the type other as requests of the type of object on Chrome 38.

However, with Chrome 39 (Canary) things get even worse. Also images and stylesheets are reported with the type other there. So lets hope that the bug will be fixed in Chrome 39 before it is released.

comment:8 Changed 3 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:9 Changed 3 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:10 Changed 3 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next

comment:11 Changed 3 years ago by sebastian

For reference, the issue that was temporarily reproducible on the Canary build, about also images and stylesheets reported with type other, is gone and didn't make it into any Chrome release.

However, the original issue, about object requests reported with type other, still persists and needs to be addressed for Chrome 39, see #1496.

Last edited 3 years ago by sebastian (previous) (diff)
Note: See TracTickets for help on using tickets.