Opened 5 years ago

Closed 5 years ago

#1388 closed change (fixed)

Update puppetlabs-postgresql module

Reported by: trev Assignee: poz2k4444
Priority: P3 Milestone:
Module: Infrastructure Keywords:
Cc: matze, fhd Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5018733013630976/
https://github.com/mjhennig/adblockplus-infrastructure/pull/9

Description

Background

We adopted the puppetlabs-postgresql module back when it was in a pretty bad shape, the current state is much more consistent. One particularly important new feature is the postgresql_escape() function that will allow us to remove the custom hacks we are currently using.

What to change

In addition to updating the dependency we will need to change a bunch of class names as outlined in the documentation. As we only use the module for Discourse this shouldn't be a big deal however.

Change History (6)

comment:1 follow-up: Changed 5 years ago by trev

  • Cc fhd added

Note that I already updated our https://hg.adblockplus.org/infrastructure-puppet-postgresql/ repository. https://hg.adblockplus.org/infrastructure-puppet-postgresql/rev/8c90d2297756 is tagged 4.0.0 (the tags sadly aren't being imported from Git into Mercurial), it would make sense to update to it.

We have two changes by Felix in the repository (https://hg.adblockplus.org/infrastructure-puppet-postgresql/rev/9dd4535a8640 and https://hg.adblockplus.org/infrastructure-puppet-postgresql/rev/0e64c5ec90f8) though only the former is actually in the state we used. I still cannot judge whether these patches are fixing a real issue, but given that we no longer use refreshonly they shouldn't be necessary.

comment:2 Changed 5 years ago by matze

  • Owner set to poz2k4444

comment:3 in reply to: ↑ 1 Changed 5 years ago by poz2k4444

Replying to trev:

Note that I already updated our https://hg.adblockplus.org/infrastructure-puppet-postgresql/ repository. https://hg.adblockplus.org/infrastructure-puppet-postgresql/rev/8c90d2297756 is tagged 4.0.0 (the tags sadly aren't being imported from Git into Mercurial), it would make sense to update to it.

Already tested in both Git and Mercurial repos with the latest update

We have two changes by Felix in the repository (https://hg.adblockplus.org/infrastructure-puppet-postgresql/rev/9dd4535a8640 and https://hg.adblockplus.org/infrastructure-puppet-postgresql/rev/0e64c5ec90f8) though only the former is actually in the state we used. I still cannot judge whether these patches are fixing a real issue, but given that we no longer use refreshonly they shouldn't be necessary.

In the latest updates those changes are not necessaries so it doesn't matter anymore.

comment:4 Changed 5 years ago by matze

  • Review URL(s) modified (diff)

comment:5 Changed 5 years ago by matze

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by poz2k4444

  • Resolution set to fixed
  • Status changed from reviewing to closed

Already merged into production

Note: See TracTickets for help on using tickets.