Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1396 closed defect (fixed)

Blocker Count increasing non-stop

Reported by: passbrains Assignee: sebastian
Priority: P3 Milestone: Adblock-Plus-1.8.6-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6317759025643520

Description (last modified by philll)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-65

Environment

Windows 7 32bit Opera English
ABP version Version 1.8.5.1221

How to reproduce

  1. Add the filter as custom filter http://www.aweber.com/images/forms/sign-up-below/small-red/button.png
  2. Go to the url http://www.softwaretestinghelp.com

Observed behaviour

selected elements got blocked, but the block count starts to increase non-stop.

Expected behaviour

Selected elements should block and block count should display the number of blocked element.

Attachments (1)

1882_1410514471_Adblock_opera2.AVI (5.3 MB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 10 Sep 2014 10:17:27 posted by Dave Barker
Please a different format than wmv for videos! (mp4, gif or swf if necessary)

2 - 10 Sep 2014 10:18:41 posted by Dave Barker
Please could you either post a new video file that I can watch or provide enough details in the description for me to reproduce the issue without watching the video? Currently I can not reproduce

3 - 10 Sep 2014 11:30:07 posted by Timo Scherf
#2 - 10 Sep 2014 10:17:27 posted by Dave Barker
Please a different format than wmv for videos! (mp4, gif or swf if necessary)

#3 - 10 Sep 2014 10:18:41 posted by Dave Barker
Please could you either post a new video file that I can watch or provide enough details in the description for me to reproduce the issue without watching the video? Currently I can not reproduce

4 - 12 Sep 2014 09:34:31 posted by Prem Anand
A file was deleted: Adblock_opera2.wmv

5 - 18 Sep 2014 14:06:49 posted by Philip Hill
I identified the following filter for being responsible for this:
http://www.aweber.com/images/forms/sign-up-below/small-red/button.png

comment:2 Changed 5 years ago by philll

  • Description modified (diff)

See also #1323

comment:3 Changed 5 years ago by sebastian

  • Component changed from Unknown to Platform
  • Owner set to sebastian
  • Platform changed from Opera to Unknown
  • Priority changed from Unknown to P3
  • Ready set

That is because <input type="image"> elements try to load their image again when the display CSS property is changed, resulting into an infinite recursion, if that image is blocked and collapsed.

comment:4 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:5 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed
Note: See TracTickets for help on using tickets.