Opened 5 years ago

Closed 4 years ago

#1422 closed change (duplicate)

Add a way to subscribe to any known filter list in Chrome, Opera and Safari

Reported by: Gingerbread Man Assignee:
Priority: P4 Milestone:
Module: User-Interface Keywords:
Cc: mapx Blocked By:
Blocking: #1524 Platform: Unknown
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by philll)

Background

Clicking "Add Filter Subscription" opens a list that isn't exhaustive. For example, it's missing some key subscriptions like EasyPrivacy. Reminder: this subscription is showcased on the Features page.

The "Add a different subscription" option only allows entering subscription details manually. Only those very familiar with Adblock Plus will have any use for this, since most won't know about the page of Known Subscriptions. And those that do will likely prefer using that page anyway, since it allows subscribing with a simple click.

What to change

The "Add Filter Subscription" list should display all known subscriptions.

Alternatively, the "Add a different subscription" option should either open the Known Subscriptions page, or a separate option that does this should be added.

Change History (12)

comment:1 Changed 5 years ago by Gingerbread Man

Also see

comment:2 follow-up: Changed 5 years ago by philll

  • Resolution set to invalid
  • Status changed from new to closed

Please note that this is a fetaure-request and not a bug. However, we already account for this with our redesigned options page.

comment:3 in reply to: ↑ 2 Changed 5 years ago by Gingerbread Man

What redesigned options page? There's nothing different in the current development build.

comment:4 Changed 5 years ago by philll

This is part of current and not yet deployed redesign work.

comment:5 follow-up: Changed 5 years ago by Gingerbread Man

No issue report, no roadmap, no blog post, no nothing?

You're making it frustratingly difficult to get involved if your answer is that you're working on this behind the scenes. It's not the first time this has happened either (ticket #1254). At least that other bug report was later reopened and the private one was marked as a duplicate (#163).

comment:6 Changed 5 years ago by philll

  • Description modified (diff)
  • Resolution invalid deleted
  • Status changed from closed to reopened
  • Summary changed from No way to subscribe to any known filter list in Chrome, Opera and Safari to Add a way to subscribe to any known filter list in Chrome, Opera and Safari
  • Type changed from defect to change

We are in fact preparing some changes internally, before we announce them officially. With the options page, we are still in the design phase, such that beyond knowing that we will very likely include your change request, no real details are ready to get announced yet. Once we have a version that we are convinced of, we will show it, to gather feedback. However, for now, your change request is still valid, so I reopen it.

comment:7 Changed 5 years ago by sebastian

  • Component changed from Platform to User-Interface
  • Platform changed from Chrome to Unknown
  • Priority changed from Unknown to P4

comment:8 in reply to: ↑ 5 Changed 5 years ago by fhd

I've got to elaborate a bit on that: The design process is, currently, rather closed. It's even closed towards most Eyeo staff in fact - mainly because we haven't yet figured out how to involve more than a handful of people in a constructive way yet (i.e. avoiding design by committee). That's not great, and it has to change.

Anyway, as opposed to design, development should (and with very few exceptions does) happen in the open. It was wrong to close this issue because something we're internally discussing (i.e. not implementing) would solve it - we should close it when it's actually fixed. That's why it was reopened.

comment:9 Changed 5 years ago by mapx

  • Cc mapx added

comment:10 Changed 5 years ago by greiner

  • Blocking 1526 added

This issue is being addressed as part of #1526.

comment:11 Changed 4 years ago by saroyanm

  • Blocking 1524 added; 1526 removed

Changed blocking ticket so I can close #1526.

comment:12 Changed 4 years ago by saroyanm

  • Resolution set to duplicate
  • Status changed from reopened to closed

This actually already covered in #1524, by recommended subscriptions implementation.

Note: See TracTickets for help on using tickets.