Opened 5 years ago

Closed 5 years ago

#1432 closed defect (duplicate)

Block element behavior is NOT proper on XML content page

Reported by: passbrains Assignee:
Priority: Unknown Milestone:
Module: Unknown Keywords:
Cc: Blocked By:
Blocking: Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-87

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.5.1227

How to reproduce

  1. Install ABP extension on Opera.
  1. Open an xml page for example

http://www.w3schools.com/xml/simple.xml

  1. Click on ABP icon and select "Block element".
  2. Move the cursor on xml content on any line.

Observe that while hovering, the selected content shows highlighted in yellow which is fine.

  1. Click on any highlighted element as shown in image 1.

Observe Issue 1 :

  1. Again click on ABP icon and select "Block element"
  2. Move the cursor on xml content on any line.

Observe Issue 2 while hovering.
 

Observed behaviour

Issue 1 : In step 5 : "Add filter" pop up doest not appear.
Issue 2 : In step 7 : Elements to be blocked are not highlighted.

Expected behaviour

Either "Block element" option shall NOT be enabled if not supported for xml page.
Or.
Add filter shall open up in Step 5.
Step 7 : Elements to be blocked shall be highlighted as happnes in step 4.

Attachments (2)

3659_1411065136_xml-image1.jpg (125.4 KB) - added by passbrains 5 years ago.
3659_1411065136_xml-image2.jpg (124.4 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (3)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by sebastian

  • Description modified (diff)
  • Resolution set to duplicate
  • Status changed from new to closed

Duplicate of #1428.

Note: See TracTickets for help on using tickets.