Opened 5 years ago

Closed 4 years ago

#1442 closed defect (rejected)

Whitelisted domains list is case sensitive though domain names are case insensitive

Reported by: passbrains Assignee:
Priority: P4 Milestone:
Module: User-Interface Keywords:
Cc: sven, saroyanm Blocked By:
Blocking: #1524 Platform: Opera
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-74

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.5.1221

How to reproduce

  1. Install ABP extension on Opera.
  2. Invoke "Adblock Plus Options" page from 'Extensions->Options.
  3. Select 'Whitelisted Domains' tab.
  4. Add any domain in whitelist in small letters. For example abc.com
  5. Add the same domain in CAPS.

example ABC.COM

  1. Observe  the domains added in whitelisted domains


Observed behaviour

Case sensitivy is not ignored and same domains are added in whitelisted domains list. This wastes space and does not add any value. 

Expected behaviour

domain names are case insensitive and same domains shall not be added in the list.
But ABP whitelisted domains list  differentiates domains on case sensitivity and adds duplicate.
 

Attachments (1)

3659_1410463058_domain.jpg (77.5 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (8)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by sebastian

  • Cc sven added
  • Component changed from Unknown to User-Interface
  • Description modified (diff)

Please consider for the new UI.

comment:2 Changed 5 years ago by sven

Good point @sebastian. I did't thought of it because it's obvious for me but the developer implementing it should be informed about this behaviour. I will have an eye on this.

comment:3 Changed 5 years ago by sven

  • Priority changed from Unknown to P5

comment:4 Changed 5 years ago by sven

  • Priority changed from P5 to P4

comment:5 Changed 5 years ago by sven

  • Blocking 1526 added

comment:6 Changed 4 years ago by saroyanm

  • Blocking 1524 added; 1526 removed

Changed blocking ticket so I can close #1526.

comment:7 Changed 4 years ago by saroyanm

  • Cc saroyanm added
  • Resolution set to rejected
  • Status changed from new to closed

This should be fixed already by #1526.

Note: See TracTickets for help on using tickets.