Opened 5 years ago

Closed 3 months ago

#1446 closed defect (rejected)

Web page's "click" event handler interferes with "Block Element"

Reported by: passbrains Assignee:
Priority: P4 Milestone:
Module: Platform Keywords: closed-in-favor-of-gitlab
Cc: sebastian Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Unknown Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-70

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.5.1221

How to reproduce

  1. Got to http://www.google.com
  2. Enter "Purifier" into the search field
  3. Open the "More" dropdown
  4. Click the ABP icon and choose "Block Element"
  5. Click on the "Books" item

Observed behaviour

The "Books" menu item is highlighted in yellow, but when clicked the "Block Element" dialog doesn't open, but the page navigates to the book search.

Expected behaviour

The page's event handler shouldn't be triggered, that no navigation happens, but the "Block Element" dialog shows up. This can be achieved by positioning an invisible click trap element over the highlighted element.

Attachments (1)

3668_1410455159_dropdownlist-image1.jpg (119.0 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (5)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Platform changed from Opera to Unknown
  • Priority changed from Unknown to P3
  • Ready set
  • Summary changed from Block element behavior is inappropriate on list items to Web page's "click" event handler interferes with "Block Element"

comment:2 Changed 5 years ago by sebastian

Also see #1373.

comment:3 Changed 2 years ago by sebastian

  • Priority changed from P3 to P4
  • Tester set to Unknown

I can no longer reproduce this issue as described. However, this is most likely just because the Google website changed a lot in 3 years. But the document cancelling event listeners, the "Block element" dialog relies on those events, might still cause side effects.

comment:4 Changed 3 months ago by sebastian

  • Keywords closed-in-favor-of-gitlab added
  • Resolution set to rejected
  • Status changed from new to closed

Sorry, but we switched to GitLab. If this issue is still relevant, please file it again in the new issue tracker.

Note: See TracTickets for help on using tickets.