Opened 5 years ago

Closed 5 years ago

Last modified 2 months ago

#1447 closed defect (incomplete)

[CRASH]ABP options page crashes on enabling/disabling ABP multiple times

Reported by: passbrains Assignee:
Priority: P2 Milestone:
Module: Platform Keywords:
Cc: greiner, sebastian Blocked By:
Blocking: Platform: Opera
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-96

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.5.1227

How to reproduce

  1. Install ABP extension on Opera.
  2. Add *** in whitelisted domain.
  1. Load any website say  https://in.yahoo.com
  2. Click on ABP and  select  Disabled on this site / Enabled on this sites  4-5 times.
  3. Observe the  ABP options page

Observed behaviour

Page crashed would be displayed

Expected behaviour

Extreme and negative conditions shall be handled graciouly.
Crash shall not occur.

Attachments (2)

3659_1411325700_crash-image1.jpg (56.8 KB) - added by passbrains 5 years ago.
3659_1411666138_yahooaftercrashpage.jpg (172.3 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by passbrains

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by passbrains

1 - 25 Sep 2014 11:20:52 posted by Thomas Greiner
I couldn't reproduce it with the following setups:

Windows Vista
Opera 24
Adblock Plus 1.8.5.1221

Ubuntu 14.04
Opera 26
Adblock Plus 1.8.5.1231

What I observe is that it removes the *** domain when clicking on "Disabled on this site" and adds "in.yahoo.com" when clicking on "Enabled on this site". After that it only removes and adds the "in.yahoo.com" entry again.

2 - 25 Sep 2014 17:27:16 posted by Rakesh Agrawal
Dear Thomas Greiner,

I am able to reproduce on latest build "Adblock Plus Version 1.8.5.1232" too.
Just done Enable=>Disable==>Enable=>Disable==>Enable

Also observed that after the page is crahed, if you see yahoo page the ABP icon near url bar also disappears.

Attaching new images.

Opera version 24.0.1558.61

3 - 26 Sep 2014 10:34:14 posted by Thomas Greiner
I was able to reproduce this issue even in recent Adblock Plus versions on Windows Vista with Opera 24 when following these steps:

  • Open options page
  • Switch to "Whitelisted domains" tab
  • Open "in.yahoo.com" in new tab
  • Click on "Enabled on this site"
  • Switch to options page tab ("in.yahoo.com" was added to the list)
  • Switch back to Yahoo tab
  • Click on "Disabled on this site"
  • Switch to options page -> extension crashes

Furthermore, I noticed that it only happens when both pages are within the same browser window.

Last edited 5 years ago by sebastian (previous) (diff)

comment:2 Changed 5 years ago by sebastian

  • Cc greiner sebastian added
  • Component changed from Unknown to Platform
  • Description modified (diff)
  • Priority changed from Unknown to P2
  • Ready set

Can you try to identify the issue, isolating it in a sample extension?

Does that also happen with Chrome? If not, please file an Opera bug and post the issue number here.

comment:3 Changed 5 years ago by greiner

Neither Chrome nor Chromium are affected by this so it's indeed an Opera-only issue. It also doesn't occur on Opera's beta builds so it doesn't appear to be necessary anymore to report that issue. But I can file a bug report if you think it could be helpful for them.

comment:4 Changed 5 years ago by sebastian

  • Resolution set to invalid
  • Status changed from new to closed

Closing as invalid, because it is an Opera bug, we might not be able to do anything about. Or at least it wouldn't be worth implementing a workaround, since it is already fixed in Opera 25.

comment:5 Changed 7 months ago by takken3

spam

Last edited 2 months ago by kzar (previous) (diff)
Note: See TracTickets for help on using tickets.