Opened 4 years ago

Last modified 4 years ago

#1454 new defect

ABP on Kindle Fire intermittently looses connection with proxyserver

Reported by: RyanNerd Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Android Keywords:
Cc: Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Kindle Fire 2nd Gen. 11.3.2.6 (not rooted)
ABP for Android 1.2.1.337 build# 337
Any web browser. Typically I use Chrome 37.0.2062.117. However this issue has appeared in Silk (Kindles built in browser) and Dolphin.

How to reproduce

  1. Installed ABP and opened it. Got a message that the connection settings need to be set manually.
  2. In network connection in advanced settings configure the connection to use localhost and port 2020.
  1. Return back to ABP configuration screen and note that the manual configuration message is gone and Filtering switch is set to ON.
  2. Set ABP to start at boot.
  3. Go to an aggressive ad website such as thepiratebay.se
  4. Go to different pages on the website and make sure ABP is working.
  5. Go to other sites. It does not matter which ones. Usually but not always the browser will display a message: Unable to connect to proxy server.
  6. Open up ABP. Sometimes the message to configure your connection manually will be back.
  7. If the message is there click on the configure manually button. ABP launches the Kindle's settings. Check that the proxy is still set to localhost:2020 (It always is. Click close and get returned back to ABP screen). The message to manually configure is now gone (even if you made no changes).
  8. Usually going into ABP fixes the proxy connection. Sometimes I've had to kill ABP and restart it to get it working again.

Observed behaviour

ABP works as expected for a time and then without any discernible pattern or event the browser will give a message that it is unable to connect to the proxy server.

Expected behaviour

ABP should always be acting as the proxy server when the Filter is ON.
I suspect that a thread or process in ABP is timing out, being blocked or getting killed.

Attachments (1)

ScreenShots.zip (395.2 KB) - added by RyanNerd 4 years ago.
Screen shots from Kindle

Download all attachments as: .zip

Change History (4)

Changed 4 years ago by RyanNerd

Screen shots from Kindle

comment:1 Changed 4 years ago by RyanNerd

I forgot to note that I had tried the stable build first and was getting this behavior. So I installed the latest dev build in hopes the problem would be solved.

comment:2 Changed 4 years ago by zkteh

I am having the same issue too~

Asus Zenfrone 5
Andriod 4.3
Latest Chrome
EasyList+ChinaList

comment:3 Changed 4 years ago by rjeschke

  • Component changed from Unknown to Adblock-Plus-for-Android
  • Priority changed from Unknown to P3
  • Ready set
Note: See TracTickets for help on using tickets.