Opened 5 years ago

Closed 4 years ago

Last modified 4 years ago

#1466 closed change (fixed)

fix usage of BSTR

Reported by: sergz Assignee: sergz
Priority: P3 Milestone: Adblock-Plus-for-Internet-Explorer-1.4
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5698769010032640/
http://codereview.adblockplus.org/5242186790600704/

Description

Background

We pass wchar_t* strings to methods which expect BSTR. The problem is that BSTR has a different layout, it has length prefix which is apparently missed in wchar_t*. So we are lucky that nobody calls SysStringLen to obtain the string length.

What to change

Pass BSTR.

Change History (5)

comment:1 Changed 4 years ago by sergz

  • Status changed from new to reviewing

comment:2 Changed 4 years ago by sergz

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 4 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.4
  • Platform changed from Unknown to Internet Explorer
  • Priority changed from Unknown to P3

comment:4 Changed 4 years ago by oleksandr

  1. This was pushed with line endings change: https://hg.adblockplus.org/adblockplusie/rev/6fd3d5ce341e
  2. There was a typo on line 280 in PluginDomTraverserBase.h. src != scr, which causes some element hiding filter to not work.

comment:5 Changed 4 years ago by oleksandr

  • Review URL(s) modified (diff)
Note: See TracTickets for help on using tickets.