Opened 5 years ago

Closed 4 years ago

#1492 closed defect (worksforme)

Block Element created filter doesn't apply to frame

Reported by: passbrains Assignee:
Priority: P3 Milestone:
Module: Platform Keywords:
Cc: saroyanm, mapx, sebastian Blocked By:
Blocking: Platform: Opera
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by saroyanm)

Adapted from https://www.passbrains.com/dashboard/view-ticket.php?ticket_no=AOP-107

Environment

Windows + Vista 64bit + Opera + English
ABP version Adblock Plus Version 1.8.5.1234

How to reproduce

  1. Install ABP extension on Opera.
  2. Load website  http://thewml.org/example/demo/
  3. Click on 3rd link  "wml::imp::csmap"  under "Includes" as shown in attached image by red circle.
  4. An image would be opened in new window in bottom.
  5. Right click on the image to block.

Filter added would be http://thewml.org/example/demo/d_incl_imp_csmap/foo.gif

  1. Reload the page.
  2. Repeat from step 3.

 

Observed behaviour

Blocked image is reloaded in step 6.

Expected behaviour

Blocked image shall not appear on reload.

Additional notes

The issue is not reproducible in Chrome, but in Opera.

Attachments (1)

3659_1412503870_csmap.jpg (119.5 KB) - added by passbrains 5 years ago.

Download all attachments as: .zip

Change History (7)

Changed 5 years ago by passbrains

comment:1 Changed 5 years ago by saroyanm

  • Description modified (diff)
  • Summary changed from Block Element does not work on Multi window content to Block Element created filter doesn't apply to frame

comment:2 Changed 5 years ago by saroyanm

  • Description modified (diff)

comment:3 Changed 5 years ago by saroyanm

  • Cc manvel@… added

comment:4 Changed 5 years ago by mapx

  • Cc saroyanm mapx added; manvel@… removed

comment:5 Changed 5 years ago by sebastian

  • Cc sebastian added
  • Component changed from Unknown to Platform
  • Priority changed from Unknown to P3
  • Ready set

comment:6 Changed 4 years ago by sebastian

  • Resolution set to worksforme
  • Status changed from new to closed

I can't reproduce this particular issue anymore, but found following related bugs: #1867, #1868, #1870

Note: See TracTickets for help on using tickets.