Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1497 closed defect (incomplete)

chrome: ABP breaks the search in inspect page

Reported by: mapx Assignee:
Priority: Unknown Milestone:
Module: Platform Keywords:
Cc: sebastian, greiner Blocked By:
Blocking: Platform: Chrome
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description (last modified by sebastian)

Environment

Chrome 39, 38 (not Chrome 36)
ABP 1.8.6.1239 (since 1.8.5)

How to reproduce

1.
open a random page (in a random site), for example:
https://adblockplus.org/forum/viewtopic.php?f=10&t=25746

right click, inspect element and do a search in the page, for example
search for when

The search does not work

2.repeat the steps above disabling completely ABP
the search is working

reported on the forum: https://adblockplus.org/forum/viewtopic.php?f=10&t=25746

Change History (5)

comment:1 Changed 5 years ago by mapx

  • Description modified (diff)

comment:2 Changed 5 years ago by mapx

  • Description modified (diff)

comment:3 Changed 5 years ago by sebastian

  • Description modified (diff)
  • Resolution set to invalid
  • Status changed from new to closed

I identified the issue and reported a Chrome bug. Since Chrome 38, attributes and text content aren't considered when searching in the inspector, on pages that use shadow DOM. This issue is triggered by Adblock Plus, since it inserts a shadow root in every web page.

comment:4 Changed 5 years ago by sebastian

Well, that was quick. Just 4 hours after I reported the bug, it was fixed in Chromium. :D

comment:5 Changed 5 years ago by mapx

probably the next chrome beta will be ok

Note: See TracTickets for help on using tickets.