Opened 5 years ago

Closed 5 years ago

#1498 closed defect (fixed)

Problems getting root in Android Lollipop

Reported by: michaelkh Assignee: fhd
Priority: P1 Milestone: Adblock-Plus-for-Android-1.3
Module: Adblock-Plus-for-Android Keywords:
Cc: rjeschke, mapx, philll Blocked By:
Blocking: Platform: Android
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6006698351263744/ (1.2.1)
http://codereview.adblockplus.org/5169693514006528/ (tip)

Description

Environment

Nexus 5 with hammerhead-lpx13d, ABP build 343, SuperSU 2.16

How to reproduce

Install latest ABP dev
Open ABP
Grant su premission

Observed behaviour

ABP offers to configure proxy.

Expected behaviour

Root mode with no proxy

Change History (15)

comment:1 Changed 5 years ago by rjeschke

I could not reproduce this issue yet, but after comparing our RootTools library version with the current and checking some commit messages this makes perfect sense.

We definitely need to upgrade our RootTools.

comment:2 Changed 5 years ago by rjeschke

  • Component changed from Unknown to Adblock-Plus-for-Android
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 5 years ago by rjeschke

  • Review URL(s) modified (diff)

comment:4 Changed 5 years ago by mapx

something from the forum (about ABP and lollipop)
https://adblockplus.org/forum/viewtopic.php?p=110320#p110320

error: only position independent executables (PIE) are supported.

when ABP attempts to execute its included iptables binary. I compiled a PIE iptables and replaced it in /data/data/org.adblockplus.android/files and the current dev build of ABP works fine then.

It looks like this is a pre-compiled binary in ABP's source. I can't figure out how to attach in this forum, but you can download my compiled iptables here:

http://xenserver.underpants-gnomes.biz/~romracer/iptables

Last edited 5 years ago by mapx (previous) (diff)

comment:5 Changed 5 years ago by mapx

  • Cc rjeschke mapx added

comment:6 Changed 5 years ago by mikhaelkh

Since Android Lollipop became stable (https://developers.google.com/android/nexus/images) and issue remains with latest SuperSU (2.19) and ABP dev (343) on hammerhead-LRX21O, let's change priority to P1.

comment:7 Changed 5 years ago by rjeschke

There's currently no need in setting a higher priority. As you can see, a possible fix is already in review.

comment:8 Changed 5 years ago by philll

  • Cc philll added

comment:9 Changed 5 years ago by fhd

  • Owner set to fhd
  • Priority changed from P2 to P1

I agree about increasing the priority: We already have 10% of our user base on Lollipop (not sure how many of those have root though). Priority doesn't have anything to do with what state the issue is in, only with how important it is.

Assigning this to me, since René is going to be afk for a while.

Last edited 5 years ago by fhd (previous) (diff)

comment:10 Changed 5 years ago by fhd

Easily reproducible on a rooted Lollipop device - crashes right on startup for me. Seems a lot like the PIE issue to me, but I'll investigate.

comment:11 Changed 5 years ago by fhd

  • Review URL(s) modified (diff)

Tested a bit, the problem here is most definitely the PIE issue indeed.

While I haven't exactly tried it with the RootTools update, I'm pretty sure this wouldn't fix it. Moving that review to #1771.

comment:12 Changed 5 years ago by fhd

  • Review URL(s) modified (diff)

Here's a review that should fix the PIE issue.

comment:13 Changed 5 years ago by fhd

  • Status changed from new to reviewing

comment:14 Changed 5 years ago by fhd

  • Review URL(s) modified (diff)

Added a patch against tip too. Once that's approved we can push this to the devbuilds.

Regarding the stable version: We still need to discuss whether we want to release 1.2.2 for this (and potentially #1667), or whether we'll rather push out 1.3 soon.

Last edited 5 years ago by fhd (previous) (diff)

comment:15 Changed 5 years ago by fhd

  • Milestone set to Adblock-Plus-for-Android-1.3
  • Resolution set to fixed
  • Status changed from reviewing to closed

Pushed to the devbuilds: https://hg.adblockplus.org/adblockplusandroid/rev/05a1649236e7

As I said, we'll consider making a 1.2.1 fix release with this.

Note: See TracTickets for help on using tickets.