Opened 6 years ago

Closed 6 years ago

Last modified 6 years ago

#152 closed defect (fixed)

patterns.ini contents are being processed multiple times

Reported by: trev Assignee: trev
Priority: P1 Milestone: Adblock-Plus-2.6-for-Firefox
Module: Adblock-Plus-for-Firefox Keywords:
Cc: Blocked By:
Blocking: #117 Platform:
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6287762160353280/

Description

Environment

Adblock Plus 2.5.1.3778

Observed behaviour

Under https://adblockplus.org/development-builds/faster-firefox-startup some users report patterns.ini content being processed multiple times causing duplicate subscriptions and bogus filters.

Analysis

This is a regression from #117. It seems to me that we considered reentrance in our code properly, it is unlikely to be the cause of the issue. However, XMLHttpRequest itself might not be reentrant - so if a new progress event fires before the previous one was handled it gets the same text once again. If that suspicion is confirmed the solution would be calling Utils.runAsync() in order to handle the data without blocking XMLHttpRequest.

Change History (6)

comment:1 Changed 6 years ago by trev

I could reproduce this issue by adding more filter subscriptions (ChinaList in particular).

Version 1, edited 6 years ago by trev (previous) (next) (diff)

comment:2 Changed 6 years ago by trev

  • Owner set to trev
  • Status changed from new to assigned

comment:3 Changed 6 years ago by trev

  • Status changed from assigned to reviewing

comment:4 Changed 6 years ago by trev

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 6 years ago by trev

  • in_progress set to 0
  • Ready unset
  • Review URL(s) modified (diff)

comment:6 Changed 6 years ago by trev

  • Milestone set to Adblock-Plus-for-Firefox-next
Note: See TracTickets for help on using tickets.