Opened 4 years ago

Closed 4 years ago

#1542 closed defect (rejected)

video grabber

Reported by: mittalsuraj18 Assignee:
Priority: P3 Milestone:
Module: Adblock-Plus-for-Internet-Explorer Keywords:
Cc: Blocked By:
Blocking: Platform: Internet Explorer
Ready: no Confidential: no
Tester: Verified working: no
Review URL(s):

Description

Environment

Windows 8.1
Internet Explorer 11.0.9600.17351
Adblock Plus for IE 1.2
EasyList filter

How to reproduce

Install Eagleget.
Install adblockPlus 1.2 for IE.
Go to any video site and play a video.

Observed behaviour

Download dialogue box doesn't appear on top of video and video monitoring doesn't work on any site for eagleget.

Expected behaviour

It should show a download dialogue box on top of video that is playing and also video sniffer in eagleget should show the video.

Change History (1)

comment:1 Changed 4 years ago by oleksandr

  • Component changed from Unknown to Adblock-Plus-for-Internet-Explorer
  • Priority changed from Unknown to P3
  • Resolution set to rejected
  • Status changed from new to closed

It looks like Eagleget and AdblockPlus seem to use the same trick to listen to traffic coming through IE (Asynchronous Pluggable Protocols). Unfortunately, currently temporary pluggable protocols are not chained, so only one pluggin that uses APP can work (see: http://msdn.microsoft.com/en-us/library/aa767759.aspx).

"Because pluggable protocol handlers are not chained, only the last handler to be registered will be active; therefore, it is better to create a new namespace, rather than reuse an existing one."

We are looking into ways of resolving this, but we don't have any immediate plans to fix this.

Note: See TracTickets for help on using tickets.