Opened 5 years ago

Closed 5 years ago

Last modified 4 years ago

#1578 closed defect (fixed)

Problem to deploy ABP V1.2 via Group Policy Object

Reported by: oleksandr Assignee: oleksandr
Priority: P2 Milestone: Adblock-Plus-for-Internet-Explorer-1.4
Module: Adblock-Plus-for-Internet-Explorer Keywords: growth, large-scale-deployments
Cc: sergz, simona, eric@… Blocked By:
Blocking: #542 Platform: Internet Explorer
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/5752158993514496/

Description

Environment

Windows 7
Service Pack 1
32 Bit
Internet Explorer 11

How to reproduce

Adopted from https://adblockplus.org/forum/viewtopic.php?f=21&t=26041.

I would like to deploy ABP via gpo. With the Version 1.0 and 1.1 (32Bit) its no problem to deploy it to a test system. But when I try the same with Version 1.2 (32bit) it doesn't work.

Observed behaviour

I find the program installed in the program list (Control Panel\Programs\Programs and Features) but not in the "IE->Tools-> Manage add-ons". I checked if maybe the ABP still work but when I open some sites I can see the advertisements on this sites. Before that with the version 1.1, I haven't seen any advertisements.

Expected behaviour

Deployment via GPO should work as expected. Plugin should be installed in Manage Add-ons and ads should be blocked.

Change History (8)

comment:1 Changed 5 years ago by sergz

  • Cc sergz added

comment:2 Changed 5 years ago by simona

  • Cc simona added
  • Keywords growth added

comment:3 Changed 5 years ago by simona

  • Keywords large-scale-deployments added

comment:4 Changed 5 years ago by oleksandr

  • Cc eric@… added

The problem here is that it is not possible to install an MSI with embedded transforms using Group Policy Object. I have been able to produce a language neutral MSI, that can be installed without problems using GPO. Domain administrators do not need embedded transforms anyway, since the GPO installation is done without UI.

I will add an installer build target to be able to automatically build a language neutral, transform-less MSI. Another option was to define TRANSFORMS=:9 installer property somehow, but that doesn't seem to be possible for GPO installation.

comment:5 Changed 5 years ago by oleksandr

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:6 Changed 5 years ago by oleksandr

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:7 Changed 4 years ago by simona

  • Blocking 542 added

comment:8 Changed 4 years ago by oleksandr

  • Milestone set to Adblock-Plus-for-Internet-Explorer-1.4
Note: See TracTickets for help on using tickets.