Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1592 closed defect (fixed)

Blocked frames aren't collapsed on Safari

Reported by: scump Assignee: sebastian
Priority: P2 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: mapx Blocked By:
Blocking: Platform: Safari
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6549206625943552

Description

Environment

OS X 10.10, Safari 8.0, ABP dev build 1.8.7.1256, EasyList, EasyPrivacy, Fanboy's Annoyance List.

How to reproduce

  1. Go to http://thepiratebay.se
  2. Search anything
  3. When the results appears, the ads are properly blocked, but the placeholders of the blocked elements aren't hidden.

http://s29.postimg.org/ynugxsuuv/Screen_Shot_2014_11_21_at_17_15_09.png

Observed behaviour

The problem occurs only with Safari. No problem with Chrome and Firefox.

Change History (5)

comment:1 Changed 5 years ago by mapx

  • Cc sebastian mapx added

comment:2 Changed 5 years ago by sebastian

  • Component changed from Unknown to Platform
  • Owner set to sebastian
  • Priority changed from Unknown to P2
  • Ready set

comment:3 Changed 5 years ago by sebastian

  • Cc sebastian removed
  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

No load event is dispatched for blocked frames, and therefore element collapsing does not work.

We stopped manually dispatching load events for blocked frames a while ago. The review documents that this isn't necessary, since Safari automatically dispatches those events for blocked frames. However, I just tested it on Safari 8 an 5.1, and with both versions of Safari no load event is dispatched.

Last edited 5 years ago by sebastian (previous) (diff)

comment:4 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:5 Changed 5 years ago by sebastian

  • Summary changed from Placeholders of blocked elements not hidden on thepiratebay.se with Safari to Blocked frames aren't collapsed on Safari
Note: See TracTickets for help on using tickets.