Opened 5 years ago

Closed 5 years ago

Last modified 5 years ago

#1593 closed defect (fixed)

Some Flash videos broken again with Chrome 40

Reported by: sebastian Assignee: sebastian
Priority: P1 Milestone: Adblock-Plus-1.8.8-for-Chrome-Opera-Safari
Module: Platform Keywords:
Cc: Blocked By:
Blocking: Platform: Unknown
Ready: yes Confidential: no
Tester: Verified working: no
Review URL(s):

http://codereview.adblockplus.org/6668950364487680

Description

Environment

Chrome 40.0.2214.10 (beta)

How to reproduce

see #1372

Observed behaviour

Since Chrome 38 requests loading <object> elements like Flash, and requests initiated by those third-party plugins are mistakenly reported by Chrome's webRequest API with the type other instead object.

This can lead to false negatives as well as false positives when using Adblock Plus. In the worst case it results in breaking entire Flash videos, as reported in #1372.

We limited the workaround we implemented for #1372 to Chrome 38. With #1496 we adapted the workaround for Chrome 39. However, Chrome 40 beta were released a few days ago, and the Chrome bug responsible hasn't been fixed yet.

Expected behaviour

Meanwhile, I don't expect Chrome bug 410382 being fixed any time soon. So Adblock Plus should work around it, on Chrome 38 and any newer version for now, as it currently only does for Chrome 38-39.

Change History (3)

comment:1 Changed 5 years ago by sebastian

  • Review URL(s) modified (diff)
  • Status changed from new to reviewing

comment:2 Changed 5 years ago by sebastian

  • Resolution set to fixed
  • Status changed from reviewing to closed

comment:3 Changed 5 years ago by sebastian

  • Milestone set to Adblock-Plus-for-Chrome-Opera-Safari-next
Note: See TracTickets for help on using tickets.